alarm/uboot-pandaboard to 2017.07-1

This commit is contained in:
Kevin Mihelich 2017-09-03 16:11:20 +00:00
parent 3d0ac3a9a1
commit 56889f9a3b
2 changed files with 14 additions and 15 deletions

View File

@ -1,20 +1,20 @@
From 594e6b23a430d13922f438d955030ceacfcc6833 Mon Sep 17 00:00:00 2001
From 43ce62b55f18bc9f26d059df0fe09b1ae8283897 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 16 Mar 2016 20:06:42 -0600
Subject: [PATCH] arch linux arm modifications
---
configs/omap4_panda_defconfig | 6 +++++-
configs/omap4_panda_defconfig | 5 ++++-
include/configs/ti_omap4_common.h | 5 ++---
2 files changed, 7 insertions(+), 4 deletions(-)
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
index 8d9024854e..e1e9d00fe6 100644
index 91e8caf541..965560c728 100644
--- a/configs/omap4_panda_defconfig
+++ b/configs/omap4_panda_defconfig
@@ -10,6 +10,10 @@ CONFIG_SYS_CONSOLE_INFO_QUIET=y
CONFIG_VERSION_VARIABLE=y
CONFIG_SPL=y
@@ -10,6 +10,10 @@ CONFIG_SPL=y
# CONFIG_SPL_EXT_SUPPORT is not set
# CONFIG_SPL_I2C_SUPPORT is not set
CONFIG_SPL_OS_BOOT=y
+CONFIG_AUTOBOOT_KEYED=y
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
@ -23,16 +23,14 @@ index 8d9024854e..e1e9d00fe6 100644
# CONFIG_CMD_IMLS is not set
CONFIG_CMD_ASKENV=y
# CONFIG_CMD_FLASH is not set
@@ -20,8 +24,8 @@ CONFIG_CMD_USB=y
@@ -20,7 +24,6 @@ CONFIG_CMD_USB=y
CONFIG_CMD_GPIO=y
# CONFIG_CMD_SETEXPR is not set
# CONFIG_CMD_NFS is not set
-CONFIG_CMD_EXT4_WRITE=y
CONFIG_MMC_OMAP_HS=y
CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_STORAGE=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
index 8e0f9eb964..e718686580 100644
--- a/include/configs/ti_omap4_common.h
@ -58,5 +56,5 @@ index 8e0f9eb964..e718686580 100644
func(DHCP, dhcp, na)
--
2.11.0
2.12.0

View File

@ -4,7 +4,7 @@
buildarch=4
pkgname=uboot-pandaboard
pkgver=2017.01
pkgver=2017.07
pkgrel=1
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
arch=('armv7h')
@ -17,8 +17,8 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'boot.txt'
'mkscr')
md5sums=('ad2d82d5b4fa548b2b95bbc26c9bad79'
'3ebdda3d4c68476fb9e04e8dcdbcd913'
md5sums=('b74741e7a9ad1cf9a5bfa87302b80f2b'
'ccd9a659e470aeeb8325dcbdafa9a847'
'4908cf55626f1109276f14111b11117d'
'021623a04afd29ac3f368977140cfbfd')
@ -35,6 +35,7 @@ build() {
make distclean
make omap4_panda_defconfig
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
make EXTRAVERSION=-${pkgrel}
}