extra/v4l-utils to 1.22.1-1

This commit is contained in:
Kevin Mihelich 2021-10-31 17:46:23 +00:00
parent 6894f3563f
commit 5d02436c02
2 changed files with 39 additions and 3 deletions

View File

@ -0,0 +1,36 @@
From 02f295d4c4c1b401cdb589df5bef2645c7f83813 Mon Sep 17 00:00:00 2001
From: Hans Verkuil <hverkuil-cisco@xs4all.nl>
Date: Mon, 15 Mar 2021 08:13:14 +0100
Subject: [PATCH] v4l2-tpg.patch: rename min/max defines to tpg_min/max
With gcc 11 the min/max defines clash with what gcc provides,
so rename these defines. They are only used in the min3/max3
defines, so the change it kept to a minimum.
Signed-off-by: Hans Verkuil <hverkuil-cisco@xs4all.nl>
Reported-by: Gregor Jasny <gjasny@googlemail.com>
---
utils/common/v4l2-tpg.h | 10 ++++------
utils/common/v4l2-tpg.patch | 12 +++++-------
2 files changed, 9 insertions(+), 13 deletions(-)
diff --git a/utils/common/v4l2-tpg.h b/utils/common/v4l2-tpg.h
index caf7b1a1..ecdb6eba 100644
--- a/utils/common/v4l2-tpg.h
+++ b/utils/common/v4l2-tpg.h
@@ -28,12 +28,10 @@ typedef __s8 s8;
#define pr_info printf
#define noinline
-#ifndef min
-#define min(a,b) ((a) < (b) ? (a) : (b))
-#define max(a,b) ((a) > (b) ? (a) : (b))
-#endif /* !min */
-#define min3(x, y, z) min((typeof(x))min(x, y), z)
-#define max3(x, y, z) max((typeof(x))max(x, y), z)
+#define tpg_min(a,b) ((a) < (b) ? (a) : (b))
+#define tpg_max(a,b) ((a) > (b) ? (a) : (b))
+#define min3(x, y, z) tpg_min((typeof(x))tpg_min(x, y), z)
+#define max3(x, y, z) tpg_max((typeof(x))tpg_max(x, y), z)
#define array_size(a, b) ((a) * (b))
#define array3_size(a, b, c) ((a) * (b) * (c))

View File

@ -4,7 +4,7 @@
# - disable distcc - configure checks for clang first
pkgname=v4l-utils
pkgver=1.20.0
pkgver=1.22.1
pkgrel=1
pkgdesc="Userspace tools and conversion library for Video 4 Linux"
arch=('x86_64')
@ -14,12 +14,12 @@ replaces=('libv4l')
conflicts=('libv4l')
backup=(etc/rc_maps.cfg)
license=('LGPL')
options=('!distcc')
makedepends=('qt5-base' 'alsa-lib')
optdepends=('qt5-base: for qv4l2' 'alsa-lib: for qv4l2')
options=('!distcc')
depends=('hicolor-icon-theme' 'gcc-libs' 'sysfsutils' 'libjpeg-turbo')
source=(https://linuxtv.org/downloads/v4l-utils/${pkgname}-${pkgver}.tar.bz2{,.asc})
sha256sums=('956118713f7ccb405c55c7088a6a2490c32d54300dd9a30d8d5008c28d3726f7'
sha256sums=('65c6fbe830a44ca105c443b027182c1b2c9053a91d1e72ad849dfab388b94e31'
'SKIP')
validpgpkeys=('05D0169C26E41593418129DF199A64FADFB500FF') # Gregor Jasny <gjasny@googlemail.com>