alarm/uboot-wandboard to 2018.03-1

This commit is contained in:
Kevin Mihelich 2018-04-01 16:09:48 +00:00
parent 38f5eca25b
commit 83f1d98c5b
2 changed files with 4 additions and 42 deletions

View File

@ -1,32 +0,0 @@
From 2119a1cd7b9bf7a762619e15ebb2a8a701055c63 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 18 Jul 2016 19:20:59 -0600
Subject: [PATCH] arch linux arm modifications
---
configs/wandboard_defconfig | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/configs/wandboard_defconfig b/configs/wandboard_defconfig
index d338ffc..0fefe3a 100644
--- a/configs/wandboard_defconfig
+++ b/configs/wandboard_defconfig
@@ -3,6 +3,10 @@ CONFIG_ARCH_MX6=y
CONFIG_SPL_GPIO_SUPPORT=y
CONFIG_SPL_LIBCOMMON_SUPPORT=y
CONFIG_SPL_LIBGENERIC_SUPPORT=y
+CONFIG_AUTOBOOT_KEYED=y
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
+CONFIG_AUTOBOOT_DELAY_STR="d"
+CONFIG_AUTOBOOT_STOP_STR=" "
CONFIG_TARGET_WANDBOARD=y
CONFIG_SPL_EXT_SUPPORT=y
CONFIG_SPL_I2C_SUPPORT=y
@@ -39,3 +43,4 @@ CONFIG_USB=y
CONFIG_USB_STORAGE=y
# CONFIG_VIDEO_SW_CURSOR is not set
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
--
2.10.2

View File

@ -4,7 +4,7 @@
buildarch=4
pkgname=uboot-wandboard
pkgver=2016.11
pkgver=2018.03
pkgrel=1
pkgdesc="U-Boot for Wandboard"
arch=('armv7h')
@ -15,19 +15,12 @@ replaces=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
install=${pkgname}.install
backup=('boot/boot.txt' 'boot/boot.scr')
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'boot.txt'
'mkscr')
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
'32b89fbb8f974ad0d57d0187d73ccd78'
md5sums=('02922bdf0ee003fe25bfc32749ffdeab'
'95f60c0ae1315e986d8a2aee15d5f854'
'021623a04afd29ac3f368977140cfbfd')
prepare() {
cd u-boot-${pkgver}
git apply ../0001-arch-linux-arm-modifications.patch
}
build() {
cd u-boot-${pkgver}
@ -35,7 +28,8 @@ build() {
make distclean
make wandboard_defconfig
make
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
make EXTRAVERSION=-${pkgrel}
}
package() {