core/gcc: drop v5 patch, update v7 fpu

This commit is contained in:
Kevin Mihelich 2022-02-06 22:20:13 +00:00
parent 0b7a43a5f5
commit 8683b7745b
2 changed files with 3 additions and 36 deletions

View File

@ -1,25 +0,0 @@
From 09eb4fbd5d0e51490da810a1ee0c6ed73c1c8688 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 7 Jan 2015 18:43:57 -0700
Subject: [PATCH] ARMv5: disable LDRD/STRD
---
gcc/config/arm/arm.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gcc/config/arm/arm.h b/gcc/config/arm/arm.h
index 4866e1e4b7d..a4bd43a364f 100644
--- a/gcc/config/arm/arm.h
+++ b/gcc/config/arm/arm.h
@@ -167,7 +167,7 @@ emission of floating point pcs attributes. */
/* Thumb-1 only. */
#define TARGET_THUMB1_ONLY (TARGET_THUMB1 && !arm_arch_notm)
-#define TARGET_LDRD (arm_arch5te && ARM_DOUBLEWORD_ALIGN \
+#define TARGET_LDRD (arm_arch6 && ARM_DOUBLEWORD_ALIGN \
&& !TARGET_THUMB1)
#define TARGET_CRC32 (arm_arch_crc)
--
2.22.0

View File

@ -11,7 +11,6 @@
# - disabled make check, too much stress, kills plugs :(
# - specifid build host, disabled distcc
# - replaced bugurl with our GitHub issue page
# - patch to disable LDRD/STRD instructions on ARMv5
noautobuild=1
@ -38,8 +37,7 @@ source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.
ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
ipa-fix-ICE-in-get_default_value.patch
gcc-ada-repro.patch
gcc11-Wno-format-security.patch
0001-ARMv5-disable-LDRD-STRD.patch)
gcc11-Wno-format-security.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
@ -54,8 +52,7 @@ sha256sums=('4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf'
'fcb11c9bcea320afd202b031b48f8750aeaedaa4b0c5dddcd2c0a16381e927e4'
'42865f2af3f48140580c4ae70b6ea03b5bdca0f29654773ef0d42ce00d60ea16'
'1773f5137f08ac1f48f0f7297e324d5d868d55201c03068670ee4602babdef2f'
'504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e'
'ac6663528a1cbea30ed9627ef41ef13f25b3cd49c31e22b45b04aa911e6f562f')
'504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e')
prepare() {
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
@ -86,15 +83,10 @@ prepare() {
patch -Np0 < "$srcdir/gcc11-Wno-format-security.patch"
# ALARM: Specify build host types, triplet patch
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft"
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=neon"
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a --enable-fix-cortex-a53-835769 --enable-fix-cortex-a53-843419"
mkdir -p "$srcdir/gcc-build"
# Disable LDRD/STRD on ARMv5 (64-bit alignment issues)
patch -p1 -i ../0001-ARMv5-disable-LDRD-STRD.patch
}
build() {