extra/avidemux to 2.8.0-1

This commit is contained in:
Kevin Mihelich 2021-12-27 16:26:04 +00:00
parent 0738cda28d
commit a0aa33503c
2 changed files with 7 additions and 21 deletions

View File

@ -6,8 +6,8 @@
pkgbase=avidemux
pkgname=('avidemux-cli' 'avidemux-qt')
pkgver=2.7.8
pkgrel=3
pkgver=2.8.0
pkgrel=1
pkgdesc='Graphical tool to edit video (filter/re-encode/split)'
url='http://fixounet.free.fr/avidemux/'
arch=('x86_64')
@ -18,18 +18,15 @@ makedepends=('cmake' 'libxslt' 'qt5-base' 'jack' 'libvorbis' 'libxv' 'opus' 'des
'libvdpau' 'libdca' 'fribidi' 'glu' 'qt5-tools' 'twolame' 'libfdk-aac' 'libass')
options=('!emptydirs')
source=(https://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz
log.diff qt-5.15.diff)
sha256sums=('628a404f521ff2812760700ae3e2aa78e5816b0ff3fb6fd05ac3e75248d97401'
'8b751d137037f22fd4ae6750709014bcf61269a18f1c32e1a91f481285c807aa'
'255a2446d493503dc237482f6fe26e2186f0ea0ef43ac9e17b8059fe232aad43')
sha512sums=('d936eb005a8418b8f3081fce599cd04bb1a256bb7cb4bf50bf2ed876658881ca76b8c6f3805da9f05614eea44eaf2d53da0f802b28ce76e754b738f2682df031'
'bbae5b4a549113b12e728c4c0ac8c1c92a0b7500be8dcecc791c16c9a913406feaa9f7bc477985970a920d2df391cc9392457512d84b9c4b829981cc072f2b2e'
'ed78c2a3e4ede4fed1d3ea353c7dc350dc73050f76c8112cb24d97b3eda01f7c186d5db199f71f56953c5e5d8104de44dc0e84e1bfa01b6647c050c11fc375f2')
log.diff)
sha256sums=('d1ec6f5277e51228ecf0ee1ca89fae24c591f520f87ce96fabec8818d04de33b'
'8b751d137037f22fd4ae6750709014bcf61269a18f1c32e1a91f481285c807aa')
sha512sums=('39905f85dbb97c455a499525541afefe262f99ce24bbacdf55ec70277325d3076546fb8a521ea4bfd88ecdcf2d04c117680346ee899f0b3198aa4b464f1f7b80'
'bbae5b4a549113b12e728c4c0ac8c1c92a0b7500be8dcecc791c16c9a913406feaa9f7bc477985970a920d2df391cc9392457512d84b9c4b829981cc072f2b2e')
prepare() {
cd ${pkgbase}_${pkgver}
patch -Np1 -i ../log.diff # don't hide the build output
patch -Np1 -i ../qt-5.15.diff # fix build against Qt 5.15.0
sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash
sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt
sed -i '/--enable-lto/d' cmake/admFFmpegBuild_native.cmake

View File

@ -1,11 +0,0 @@
diff -u -r avidemux_2.7.4/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp avidemux_2.7.4-fix/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp
--- avidemux_2.7.4/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp 2019-08-15 07:25:39.000000000 +0000
+++ avidemux_2.7.4-fix/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp 2020-06-05 13:48:28.014061206 +0000
@@ -8,6 +8,7 @@
***************************************************************************///
#include <QPainter>
+#include <QPainterPath>
#include <QRubberBand>
#include <QBoxLayout>
#include <QSizeGrip>