community/sshfs to 3.7.2-2

This commit is contained in:
Kevin Mihelich 2021-10-05 22:54:35 +00:00
parent 5554a4749d
commit b0cf36fcc2
3 changed files with 7 additions and 36 deletions

View File

@ -1,12 +0,0 @@
diff -ura sshfs-3.3.0.orig/meson.build sshfs-3.3.0.new/meson.build
--- sshfs-3.3.0.orig/meson.build 2017-09-20 14:08:27.000000000 -0300
+++ sshfs-3.3.0.new/meson.build 2017-09-25 11:19:19.946623793 -0300
@@ -58,7 +58,7 @@
if rst2man.found()
custom_target('manpages', input: [ 'sshfs.rst' ], output: [ 'sshfs.1' ],
command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
- install_dir: join_paths(get_option('mandir'), '1'))
+ install_dir: join_paths(get_option('mandir'), 'man1'))
else
message('rst2man not found, not building manual page.')
endif

View File

@ -1,21 +0,0 @@
diff -ura sshfs-3.3.0.orig/sshfs.c sshfs-3.3.0.new/sshfs.c
--- sshfs-3.3.0.orig/sshfs.c 2017-09-20 14:08:27.000000000 -0300
+++ sshfs-3.3.0.new/sshfs.c 2017-10-01 23:04:23.048755162 -0300
@@ -428,9 +428,15 @@
FUSE_OPT_KEY("writeback_cache=no", FUSE_OPT_KEY_DISCARD),
FUSE_OPT_KEY("unreliable_append", FUSE_OPT_KEY_DISCARD),
-
- FUSE_OPT_END
+ /* These may come in from /etc/fstab - we just ignore them */
+ FUSE_OPT_KEY("auto", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_KEY("noauto", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_KEY("user", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_KEY("nouser", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_KEY("users", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_KEY("_netdev", FUSE_OPT_KEY_DISCARD),
+ FUSE_OPT_END
};
static struct fuse_opt workaround_opts[] = {

View File

@ -7,21 +7,25 @@
pkgname=sshfs
pkgver=3.7.2
pkgrel=1
pkgrel=2
pkgdesc="FUSE client based on the SSH File Transfer Protocol"
arch=('x86_64')
url="https://github.com/libfuse/sshfs"
license=(GPL)
depends=(fuse3 glib2 openssh)
makedepends=('meson' 'python-docutils')
source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc})
source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc}
https://github.com/libfuse/sshfs/commit/508e8cb0.patch)
sha256sums=('1c596d42724d13aeba9f49ee127b8ef2fdeb813e25c6018f92d0c9ec4754fa2d'
'SKIP')
'SKIP'
'629f0f07e1efd6c8251750c29981f106caa8fc4e12338c2092376054bfec059b')
validpgpkeys=('ED31791B2C5C1613AF388B8AD113FCAC3C4E599F') # Nikolaus Rath <Nikolaus@rath.org>
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../508e8cb0.patch # Fix typo that prevents passing the PubkeyAcceptedKeyTypes option to ssh
[[ $CARCH == 'arm' || $CARCH == 'armv6h' || $CARCH == 'armv7h' ]] && export CFLAGS+=" -D_FILE_OFFSET_BITS=64"
rm -rf build
mkdir build