removed community/js185

This commit is contained in:
Kevin Mihelich 2022-02-07 06:20:38 +00:00
parent 45de283e01
commit e8896100e1
9 changed files with 0 additions and 764 deletions

View File

@ -1,22 +0,0 @@
From: Mike Hommey <mh@glandium.org>
Date: Fri, 18 Mar 2011 09:25:57 +0100
Subject: Bug 638056 - Avoid "The cacheFlush support is missing on this
platform" error on exotic platforms
---
js/src/Makefile.in | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
Index: mozjs-1.8.5-1.0.0+dfsg/js/src/Makefile.in
===================================================================
--- mozjs-1.8.5-1.0.0+dfsg.orig/js/src/Makefile.in 2012-01-21 15:57:37.499703219 +0100
+++ mozjs-1.8.5-1.0.0+dfsg/js/src/Makefile.in 2012-01-21 15:57:40.523703229 +0100
@@ -382,7 +382,7 @@
# END enclude sources for V8 dtoa
#############################################
-ifeq (,$(filter-out powerpc sparc,$(TARGET_CPU)))
+ifeq (,$(filter arm %86 x86_64,$(TARGET_CPU)))
VPATH += $(srcdir)/assembler \
$(srcdir)/assembler/wtf \

View File

@ -1,90 +0,0 @@
# Maintainer: Bruno Pagani <archange@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix mozilla stupidity
# - patch to fix mozilla stupidity
# - patch for AArch64
pkgname=js185
pkgver=1.0.0
pkgrel=9
pkgdesc="JavaScript interpreter and libraries (legacy)"
arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/1.8.5"
license=(MPL)
depends=(nspr libffi)
makedepends=(python2 zip)
source=("https://ftp.mozilla.org/pub/mozilla.org/js/${pkgname}-${pkgver}.tar.gz"
'fix-gcc6.patch'
'fix-install-symlinks.patch'
'system-libffi-autoconf.patch'
'allow-to-build-against-system-libffi.patch'
'apache-couchdb-mozjs-tag.patch'
ihatemozilla.patch no-neon.patch
Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch)
sha256sums=('5d12f7e1f5b4a99436685d97b9b7b75f094d33580227aa998c406bbae6f2a687'
'7d252ea688f3011360c3a370820e1a00c85ae785cdad37c6655d0d5ef996fb76'
'b738dc60b6f9c4697aede30ca09a87ac0d5895fe5da6c9f277295531cbe8c215'
'524e11a66f0931dc1affcfcf47a87e086b6006ee9b747e2c7caae82334d6ba6b'
'eea3f80f72cfde52745fbb24b9d3a3506dd2cdbb08fe53a529d7c9a14f0381a6'
'669b2e87f962ef554ab8e7940d1dbf4e0e437b96ed3001a3b9ef124492a686d0'
'40d3f2778ff111bf75c736018a25c5d5cf02585a1981430d18dd2ec030414771'
'99bc474f881950c3d65b09d7a912115cc209d7fbfb4223a819b75d393bd49586'
'2f3fdaa47825835d3b54453c0cfb201f15aee2d12631a244106243d2ff5594e5')
prepare() {
find . -name config.sub -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.sub {} \;
find . -name config.guess -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.guess {} \;
cd js-1.8.5
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811665
patch -p1 -i ../fix-gcc6.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=628723
patch -p1 -i ../fix-install-symlinks.patch
patch -p1 -i ../system-libffi-autoconf.patch
patch -p1 -i ../allow-to-build-against-system-libffi.patch
patch -p1 -i ../apache-couchdb-mozjs-tag.patch
patch -p1 -i ../ihatemozilla.patch
patch -p1 -i ../no-neon.patch
if [[ $CARCH == "aarch64" ]]; then
patch -p1 -i ../Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch
fi
}
build() {
cd js-1.8.5/js/src
# _FORTIFY_SOURCE causes the following configure error:
# checking for the alignment of void*... configure: error: No alignment found for void*
unset CPPFLAGS
./configure \
--prefix=/usr \
--with-system-nspr \
--disable-tests \
--disable-optimize \
--disable-profile-guided-optimization \
--disable-methodjit \
--enable-ctypes \
--enable-jemalloc \
--enable-readline \
--enable-threadsafe \
--enable-system-ffi
make
}
package() {
cd js-1.8.5/js/src
make DESTDIR="${pkgdir}" install
install -Dm755 shell/js -t "${pkgdir}"/usr/bin/
find "${pkgdir}"/usr/{lib/pkgconfig,include} -type f -exec chmod -x {} +
# Remove static lib (!staticlibs does not work because name do not match)
rm "${pkgdir}"/usr/lib/libmozjs185-1.0.a
}

View File

@ -1,116 +0,0 @@
From: Mike Hommey <mh@glandium.org>
Date: Tue, 9 Mar 2010 09:44:37 +0100
Subject: Allow to build against system libffi
https://bugzilla.mozilla.org/show_bug.cgi?id=551138
---
js/src/Makefile.in | 16 ++++++++++++++--
js/src/config/autoconf.mk.in | 4 ++++
js/src/configure.in | 14 +++++++++++++-
js/src/shell/Makefile.in | 3 +++
4 files changed, 34 insertions(+), 3 deletions(-)
--- a/js/src/Makefile.in
+++ b/js/src/Makefile.in
@@ -453,11 +453,20 @@ CPPSRCS += \
Library.cpp \
$(NULL)
-LOCAL_INCLUDES = \
- -Ictypes/libffi/include \
+ifdef MOZ_NATIVE_FFI
+LOCAL_INCLUDES = $(MOZ_FFI_CFLAGS)
+else
+LOCAL_INCLUDES = -Ictypes/libffi/include
+endif
+
+LOCAL_INCLUDES += \
-I. \
$(NULL)
+
+ifdef MOZ_NATIVE_FFI
+EXTRA_DSO_LDOPTS += $(MOZ_FFI_LIBS)
+else
ifeq ($(OS_ARCH),OS2)
SHARED_LIBRARY_LIBS += \
ctypes/libffi/.libs/ffi.a \
@@ -467,6 +476,7 @@ SHARED_LIBRARY_LIBS += \
ctypes/libffi/.libs/libffi.$(LIB_SUFFIX) \
$(NULL)
endif
+endif
endif # JS_HAS_CTYPES
@@ -546,6 +556,7 @@ endif
include $(topsrcdir)/config/rules.mk
ifdef JS_HAS_CTYPES
+ifndef MOZ_NATIVE_FFI
# Build libffi proper as part of the 'exports' target, so things get built
# in the right order.
export::
@@ -554,6 +565,7 @@ export::
distclean clean::
$(call SUBMAKE,$@,ctypes/libffi)
endif
+endif
ifdef MOZ_SYNC_BUILD_FILES
# Because the SpiderMonkey can be distributed and built independently
--- a/js/src/config/autoconf.mk.in
+++ b/js/src/config/autoconf.mk.in
@@ -250,6 +250,10 @@ NSPR_CONFIG = @NSPR_CONFIG@
NSPR_CFLAGS = @NSPR_CFLAGS@
NSPR_LIBS = @NSPR_LIBS@
+MOZ_NATIVE_FFI = @MOZ_NATIVE_FFI@
+MOZ_FFI_LIBS = @MOZ_FFI_LIBS@
+MOZ_FFI_CFLAGS = @MOZ_FFI_CFLAGS@
+
USE_DEPENDENT_LIBS = @USE_DEPENDENT_LIBS@
JS_NATIVE_EDITLINE = @JS_NATIVE_EDITLINE@
--- a/js/src/configure.in
+++ b/js/src/configure.in
@@ -4591,6 +4591,18 @@ if test -n "$MOZ_NATIVE_NSPR"; then
CFLAGS=$_SAVE_CFLAGS
fi
+dnl system libffi Support
+dnl ========================================================
+MOZ_ARG_ENABLE_BOOL(system-ffi,
+[ --enable-system-ffi Use system libffi (located with pkgconfig)],
+ MOZ_NATIVE_FFI=1 )
+
+if test -n "$MOZ_NATIVE_FFI"; then
+ PKG_CHECK_MODULES(MOZ_FFI, libffi)
+fi
+
+AC_SUBST(MOZ_NATIVE_FFI)
+
dnl ========================================================
dnl =
dnl = Application
@@ -6074,7 +6086,7 @@ AC_MSG_RESULT(invoking make to create js
$GMAKE js-config
# Build jsctypes if it's enabled.
-if test "$JS_HAS_CTYPES"; then
+if test "$JS_HAS_CTYPES" -a -z "$MOZ_NATIVE_FFI"; then
# Run the libffi 'configure' script.
ac_configure_args="--disable-shared --enable-static --disable-raw-api"
if test "$MOZ_DEBUG"; then
--- a/js/src/shell/Makefile.in
+++ b/js/src/shell/Makefile.in
@@ -53,6 +53,9 @@ CPPSRCS = \
DEFINES += -DEXPORT_JS_API
LIBS = $(NSPR_LIBS) $(EDITLINE_LIBS) $(DEPTH)/$(LIB_PREFIX)js_static.$(LIB_SUFFIX)
+ifdef MOZ_NATIVE_FFI
+EXTRA_LIBS += $(MOZ_FFI_LIBS)
+endif
LOCAL_INCLUDES += -I$(topsrcdir) -I..

View File

@ -1,96 +0,0 @@
--- js-1.8.5/js/src/jsval.h 2017-03-10 16:27:06.000000000 +0100
+++ js-1.8.5/js/src/jsval.h 2017-03-10 16:30:39.000000000 +0100
@@ -66,7 +66,7 @@ JS_BEGIN_EXTERN_C
#endif
#if JS_BITS_PER_WORD == 64
-# define JSVAL_TAG_SHIFT 47
+# define JSVAL_TAG_SHIFT 48
#endif
/*
@@ -135,7 +135,8 @@ JS_STATIC_ASSERT(sizeof(JSValueTag) == 4
/* Remember to propagate changes to the C defines below. */
JS_ENUM_HEADER(JSValueTag, uint32)
{
- JSVAL_TAG_MAX_DOUBLE = 0x1FFF0,
+ JSVAL_TAG_DUMMY = 0xFFFFFFFF, /* Make sure the enums cannot fit 16-bits. */
+ JSVAL_TAG_MAX_DOUBLE = 0xFFF8,
JSVAL_TAG_INT32 = JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_INT32,
JSVAL_TAG_UNDEFINED = JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_UNDEFINED,
JSVAL_TAG_STRING = JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_STRING,
@@ -196,7 +197,7 @@ typedef uint32 JSValueTag;
#elif JS_BITS_PER_WORD == 64
typedef uint32 JSValueTag;
-#define JSVAL_TAG_MAX_DOUBLE ((uint32)(0x1FFF0))
+#define JSVAL_TAG_MAX_DOUBLE ((uint32)(0xFFF8))
#define JSVAL_TAG_INT32 (uint32)(JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_INT32)
#define JSVAL_TAG_UNDEFINED (uint32)(JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_UNDEFINED)
#define JSVAL_TAG_STRING (uint32)(JSVAL_TAG_MAX_DOUBLE | JSVAL_TYPE_STRING)
@@ -236,8 +237,8 @@ typedef uint64 JSValueShiftedTag;
#elif JS_BITS_PER_WORD == 64
-#define JSVAL_PAYLOAD_MASK 0x00007FFFFFFFFFFFLL
-#define JSVAL_TAG_MASK 0xFFFF800000000000LL
+#define JSVAL_PAYLOAD_MASK 0x0000FFFFFFFFFFFFLL
+#define JSVAL_TAG_MASK 0xFFFF000000000000LL
#define JSVAL_TYPE_TO_TAG(type) ((JSValueTag)(JSVAL_TAG_MAX_DOUBLE | (type)))
#define JSVAL_TYPE_TO_SHIFTED_TAG(type) (((uint64)JSVAL_TYPE_TO_TAG(type)) << JSVAL_TAG_SHIFT)
@@ -297,8 +298,8 @@ typedef union jsval_layout
#if (!defined(_WIN64) && defined(__cplusplus))
/* MSVC does not pack these correctly :-( */
struct {
- uint64 payload47 : 47;
- JSValueTag tag : 17;
+ uint64 payload48 : 48;
+ JSValueTag tag : 16;
} debugView;
#endif
struct {
@@ -339,8 +340,8 @@ typedef union jsval_layout
{
uint64 asBits;
struct {
- JSValueTag tag : 17;
- uint64 payload47 : 47;
+ JSValueTag tag : 16;
+ uint64 payload48 : 48;
} debugView;
struct {
uint32 padding;
--- js-1.8.5/js/src/jsvalue.h 2017-03-10 16:27:06.000000000 +0100
+++ js-1.8.5/js/src/jsvalue.h 2017-03-10 16:27:06.000000000 +0100
@@ -255,7 +255,7 @@ JSVAL_SAME_TYPE_IMPL(jsval_layout lhs, j
{
uint64 lbits = lhs.asBits, rbits = rhs.asBits;
return (lbits <= JSVAL_TAG_MAX_DOUBLE && rbits <= JSVAL_TAG_MAX_DOUBLE) ||
- (((lbits ^ rbits) & 0xFFFF800000000000LL) == 0);
+ (((lbits ^ rbits) & 0xFFFF000000000000LL) == 0);
}
static JS_ALWAYS_INLINE jsval_layout
@@ -277,7 +277,7 @@ JSVAL_TO_PRIVATE_UINT32_IMPL(jsval_layou
static JS_ALWAYS_INLINE JSValueType
JSVAL_EXTRACT_NON_DOUBLE_TYPE_IMPL(jsval_layout l)
{
- uint64 type = (l.asBits >> JSVAL_TAG_SHIFT) & 0xF;
+ uint64 type = (l.asBits >> JSVAL_TAG_SHIFT) & 0x7;
JS_ASSERT(type > JSVAL_TYPE_DOUBLE);
return (JSValueType)type;
}
--- js-1.8.5/js/src/methodjit/MethodJIT.cpp 2011-03-31 21:08:36.000000000 +0200
+++ js-1.8.5/js/src/methodjit/MethodJIT.cpp 2017-03-10 16:27:06.000000000 +0100
@@ -186,8 +186,8 @@ JS_STATIC_ASSERT(sizeof(VMFrame) % 16 ==
JS_STATIC_ASSERT(offsetof(VMFrame, savedRBX) == 0x58);
JS_STATIC_ASSERT(offsetof(VMFrame, regs.fp) == 0x38);
-JS_STATIC_ASSERT(JSVAL_TAG_MASK == 0xFFFF800000000000LL);
-JS_STATIC_ASSERT(JSVAL_PAYLOAD_MASK == 0x00007FFFFFFFFFFFLL);
+JS_STATIC_ASSERT(JSVAL_TAG_MASK == 0xFFFF000000000000LL);
+JS_STATIC_ASSERT(JSVAL_PAYLOAD_MASK == 0x0000FFFFFFFFFFFFLL);
asm volatile (
".text\n"

View File

@ -1,153 +0,0 @@
Description: Fix FTBFS with gcc6
Most fixes are returning NULL instead of false and a narrowing issues.
Author: Tobias Frost <tobi@debian.org>
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811665
Last-Update: 2016-09-25
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/js/src/ctypes/CTypes.cpp
+++ b/js/src/ctypes/CTypes.cpp
@@ -4753,7 +4753,7 @@ NewFunctionInfo(JSContext* cx,
for (JSUint32 i = 0; i < argLength; ++i) {
bool isEllipsis;
if (!IsEllipsis(cx, argTypes[i], &isEllipsis))
- return false;
+ return NULL;
if (isEllipsis) {
fninfo->mIsVariadic = true;
if (i < 1) {
--- a/js/src/jsapi.cpp
+++ b/js/src/jsapi.cpp
@@ -3985,7 +3985,7 @@ JS_Enumerate(JSContext *cx, JSObject *ob
AutoIdVector props(cx);
JSIdArray *ida;
if (!GetPropertyNames(cx, obj, JSITER_OWNONLY, &props) || !VectorToIdArray(cx, props, &ida))
- return false;
+ return NULL;
for (size_t n = 0; n < size_t(ida->length); ++n)
JS_ASSERT(js_CheckForStringIndex(ida->vector[n]) == ida->vector[n]);
return ida;
--- a/js/src/jsfun.cpp
+++ b/js/src/jsfun.cpp
@@ -2051,7 +2051,7 @@ fun_toStringHelper(JSContext *cx, JSObje
JSString *str = JS_DecompileFunction(cx, fun, indent);
if (!str)
- return false;
+ return NULL;
if (!indent)
cx->compartment->toSourceCache.put(fun, str);
@@ -2657,7 +2657,7 @@ LookupInterpretedFunctionPrototype(JSCon
const Shape *shape = funobj->nativeLookup(id);
if (!shape) {
if (!ResolveInterpretedFunctionPrototype(cx, funobj))
- return false;
+ return NULL;
shape = funobj->nativeLookup(id);
}
JS_ASSERT(!shape->configurable());
--- a/js/src/jsiter.cpp
+++ b/js/src/jsiter.cpp
@@ -425,7 +425,7 @@ NewIteratorObject(JSContext *cx, uintN f
*/
JSObject *obj = js_NewGCObject(cx, FINALIZE_OBJECT0);
if (!obj)
- return false;
+ return NULL;
obj->init(cx, &js_IteratorClass, NULL, NULL, NULL, false);
obj->setMap(cx->compartment->emptyEnumeratorShape);
return obj;
--- a/js/src/jsparse.cpp
+++ b/js/src/jsparse.cpp
@@ -3352,7 +3352,7 @@ Parser::functionDef(JSAtom *funAtom, Fun
if (!outertc->inFunction() && bodyLevel && funAtom && !lambda && outertc->compiling()) {
JS_ASSERT(pn->pn_cookie.isFree());
if (!DefineGlobal(pn, outertc->asCodeGenerator(), funAtom))
- return false;
+ return NULL;
}
pn->pn_blockid = outertc->blockid();
--- a/js/src/jsstr.cpp
+++ b/js/src/jsstr.cpp
@@ -1734,7 +1734,7 @@ class RegExpGuard
if (flat) {
patstr = flattenPattern(cx, fm.patstr);
if (!patstr)
- return false;
+ return NULL;
} else {
patstr = fm.patstr;
}
@@ -3400,7 +3400,7 @@ js_InitStringClass(JSContext *cx, JSObje
UndefinedValue(), NULL, NULL,
JSPROP_READONLY | JSPROP_PERMANENT | JSPROP_SHARED, 0, 0,
NULL)) {
- return JS_FALSE;
+ return NULL;
}
return proto;
--- a/js/src/jstypedarray.cpp
+++ b/js/src/jstypedarray.cpp
@@ -1334,7 +1334,7 @@ class TypedArrayTemplate
if (size != 0 && count >= INT32_MAX / size) {
JS_ReportErrorNumber(cx, js_GetErrorMessage, NULL,
JSMSG_NEED_DIET, "size and count");
- return false;
+ return NULL;
}
int32 bytelen = size * count;
@@ -1668,7 +1668,7 @@ TypedArrayConstruct(JSContext *cx, jsint
default:
JS_NOT_REACHED("shouldn't have gotten here");
- return false;
+ return NULL;
}
}
--- a/js/src/jsxml.cpp
+++ b/js/src/jsxml.cpp
@@ -282,7 +282,7 @@ NewXMLNamespace(JSContext *cx, JSLinearS
obj = NewBuiltinClassInstanceXML(cx, &js_NamespaceClass);
if (!obj)
- return JS_FALSE;
+ return NULL;
JS_ASSERT(JSVAL_IS_VOID(obj->getNamePrefixVal()));
JS_ASSERT(JSVAL_IS_VOID(obj->getNameURIVal()));
JS_ASSERT(JSVAL_IS_VOID(obj->getNamespaceDeclared()));
@@ -431,7 +431,7 @@ ConvertQNameToString(JSContext *cx, JSOb
size_t length = str->length();
jschar *chars = (jschar *) cx->malloc((length + 2) * sizeof(jschar));
if (!chars)
- return JS_FALSE;
+ return NULL;
*chars = '@';
const jschar *strChars = str->getChars(cx);
if (!strChars) {
--- a/js/src/methodjit/InvokeHelpers.cpp
+++ b/js/src/methodjit/InvokeHelpers.cpp
@@ -728,7 +728,7 @@ AtSafePoint(JSContext *cx)
{
JSStackFrame *fp = cx->fp();
if (fp->hasImacropc())
- return false;
+ return NULL;
JSScript *script = fp->script();
return script->maybeNativeCodeForPC(fp->isConstructing(), cx->regs->pc);
--- a/js/src/nanojit/NativeX64.cpp
+++ b/js/src/nanojit/NativeX64.cpp
@@ -1899,7 +1899,7 @@ namespace nanojit
}
}
- static const AVMPLUS_ALIGN16(int64_t) negateMask[] = {0x8000000000000000LL,0};
+ static const AVMPLUS_ALIGN16(int64_t) negateMask[] = {(int64_t) 0x8000000000000000ULL,0};
void Assembler::asm_fneg(LIns *ins) {
Register rr, ra;

View File

@ -1,15 +0,0 @@
https://bugzilla.mozilla.org/show_bug.cgi?id=628723#c43
--- a/js/src/Makefile.in
+++ b/js/src/Makefile.in
@@ -888,8 +888,8 @@ endif
ifeq (,$(HOST_BIN_SUFFIX))
mv -f $(SHLIB_ANY_VER) $(SHLIB_EXACT_VER)
@[ ! -h $(SHLIB_ABI_VER) ] || rm -f $(SHLIB_ABI_VER)
- ln -s $(SHLIB_EXACT_VER) $(SHLIB_ABI_VER)
- ln -s $(SHLIB_ABI_VER) $(SHLIB_ANY_VER)
+ ln -s $(notdir $(SHLIB_EXACT_VER)) $(SHLIB_ABI_VER)
+ ln -s $(notdir $(SHLIB_ABI_VER)) $(SHLIB_ANY_VER)
endif
endif
ifneq (,$(IMPORT_LIBRARY))

View File

@ -1,33 +0,0 @@
diff -urN js-1.8.5.orig/js/src/configure js-1.8.5/js/src/configure
--- js-1.8.5.orig/js/src/configure 2011-03-31 13:08:36.000000000 -0600
+++ js-1.8.5/js/src/configure 2011-11-29 18:13:45.000000000 -0700
@@ -13322,13 +13322,9 @@
case "$target_cpu" in
arm*)
if test "$GNU_CC"; then
- cat >> confdefs.h <<\EOF
-#define MOZ_ARM_ARCH 1
-EOF
-
- CFLAGS="$CFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
- CXXFLAGS="$CXXFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
- ASFLAGS="$ASFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
+ CFLAGS="$CFLAGS"
+ CXXFLAGS="$CXXFLAGS"
+ ASFLAGS="$ASFLAGS"
else
{ echo "configure: error: --with-cpu-arch=armv7 is not supported for non-GNU toolchains" 1>&2; exit 1; }
fi
@@ -13341,9 +13337,9 @@
case "$target_cpu" in
arm*)
if test "$GNU_CC"; then
- CFLAGS="$CFLAGS -march=armv5te -mthumb-interwork -msoft-float"
- CXXFLAGS="$CXXFLAGS -march=armv5te -mthumb-interwork -msoft-float"
- ASFLAGS="$ASFLAGS -march=armv5te -mthumb-interwork -msoft-float"
+ CFLAGS="$CFLAGS"
+ CXXFLAGS="$CXXFLAGS"
+ ASFLAGS="$ASFLAGS"
fi
;;
esac

View File

@ -1,76 +0,0 @@
diff -urN a/js/src/configure b/js/src/configure
--- a/js/src/configure 2011-03-31 13:08:36.000000000 -0600
+++ b/js/src/configure 2014-02-05 15:19:39.915096224 -0700
@@ -10603,72 +10603,6 @@
esac
-echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:10608: checking for ARM SIMD support in compiler" >&5
-cat > conftest.$ac_ext <<EOF
-#line 10610 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:10617: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
-echo "$ac_t"""$result"" 1>&6
-if test "$result" = "yes"; then
- cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
-fi
-
-
-echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:10638: checking for ARM NEON support in compiler" >&5
-_SAVE_CFLAGS="$CFLAGS"
-if test "$GNU_CC"; then
- # gcc needs -mfpu=neon to recognize NEON instructions
- CFLAGS="$CFLAGS -mfpu=neon -mfloat-abi=softfp"
-fi
-cat > conftest.$ac_ext <<EOF
-#line 10645 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:10652: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
-echo "$ac_t"""$result"" 1>&6
-if test "$result" = "yes"; then
- cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
-fi
-CFLAGS="$_SAVE_CFLAGS"
-
-
case "$target_os" in
darwin*)
USE_PTHREADS=1

View File

@ -1,163 +0,0 @@
--- a/js/src/configure
+++ b/js/src/configure
@@ -99,6 +99,8 @@ ac_help="$ac_help
--with-nspr-exec-prefix=PFX
Exec prefix where NSPR is installed"
ac_help="$ac_help
+ --enable-system-ffi Use system libffi (located with pkgconfig)"
+ac_help="$ac_help
--with-arm-kuser Use kuser helpers (Linux/ARM only -- requires kernel 2.6.13 or later)"
ac_help="$ac_help
--enable-ui-locale=ab-CD
@@ -13204,19 +13206,128 @@ rm -f conftest*
CFLAGS=$_SAVE_CFLAGS
fi
+# Check whether --enable-system-ffi or --disable-system-ffi was given.
+if test "${enable_system_ffi+set}" = set; then
+ enableval="$enable_system_ffi"
+ if test "$enableval" = "yes"; then
+ MOZ_NATIVE_FFI=1
+ elif test "$enableval" = "no"; then
+ :
+ else
+ { echo "configure: error: Option, system-ffi, does not take an argument ($enableval)." 1>&2; exit 1; }
+ fi
+fi
+
+
+if test -n "$MOZ_NATIVE_FFI"; then
+ succeeded=no
+
+ if test -z "$PKG_CONFIG"; then
+ # Extract the first word of "pkg-config", so it can be a program name with args.
+set dummy pkg-config; ac_word=$2
+echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+echo "configure:13210: checking for $ac_word" >&5
+if eval "test \"`echo '$''{'ac_cv_path_PKG_CONFIG'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ case "$PKG_CONFIG" in
+ /*)
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
+ ;;
+ ?:/*)
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a dos path.
+ ;;
+ *)
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+ ac_dummy="$PATH"
+ for ac_dir in $ac_dummy; do
+ test -z "$ac_dir" && ac_dir=.
+ if test -f $ac_dir/$ac_word; then
+ ac_cv_path_PKG_CONFIG="$ac_dir/$ac_word"
+ break
+ fi
+ done
+ IFS="$ac_save_ifs"
+ test -z "$ac_cv_path_PKG_CONFIG" && ac_cv_path_PKG_CONFIG="no"
+ ;;
+esac
+fi
+PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
+if test -n "$PKG_CONFIG"; then
+ echo "$ac_t""$PKG_CONFIG" 1>&6
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+ fi
+
+ if test "$PKG_CONFIG" = "no" ; then
+ echo "*** The pkg-config script could not be found. Make sure it is"
+ echo "*** in your path, or set the PKG_CONFIG environment variable"
+ echo "*** to the full path to pkg-config."
+ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
+ else
+ PKG_CONFIG_MIN_VERSION=0.9.0
+ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
+ echo $ac_n "checking for libffi""... $ac_c" 1>&6
+echo "configure:13254: checking for libffi" >&5
+
+ if $PKG_CONFIG --exists "libffi" ; then
+ echo "$ac_t""yes" 1>&6
+ succeeded=yes
+
+ echo $ac_n "checking MOZ_FFI_CFLAGS""... $ac_c" 1>&6
+echo "configure:13261: checking MOZ_FFI_CFLAGS" >&5
+ MOZ_FFI_CFLAGS=`$PKG_CONFIG --cflags "libffi"`
+ echo "$ac_t""$MOZ_FFI_CFLAGS" 1>&6
+
+ echo $ac_n "checking MOZ_FFI_LIBS""... $ac_c" 1>&6
+echo "configure:13266: checking MOZ_FFI_LIBS" >&5
+ ## Remove evil flags like -Wl,--export-dynamic
+ MOZ_FFI_LIBS="`$PKG_CONFIG --libs \"libffi\" |sed s/-Wl,--export-dynamic//g`"
+ echo "$ac_t""$MOZ_FFI_LIBS" 1>&6
+ else
+ MOZ_FFI_CFLAGS=""
+ MOZ_FFI_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+ MOZ_FFI_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libffi"`
+ echo $MOZ_FFI_PKG_ERRORS
+ fi
+
+
+
+ else
+ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
+ echo "*** See http://www.freedesktop.org/software/pkgconfig"
+ fi
+ fi
+
+ if test $succeeded = yes; then
+ :
+ else
+ if test "$COMPILE_ENVIRONMENT"; then
+ { echo "configure: error: Library requirements (libffi) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." 1>&2; exit 1; }
+ fi
+ fi
+
+fi
+
+
+
# Application
BUILD_STATIC_LIBS=
ENABLE_TESTS=1
MOZ_THUMB2=
USE_ARM_KUSER=
case "${target}" in
arm-android-eabi)
USE_ARM_KUSER=1
MOZ_THUMB2=1
;;
esac
@@ -15741,9 +15851,13 @@ s%@HAVE_GCC3_ABI@%$HAVE_GCC3_ABI%g
s%@NSPR_CFLAGS@%$NSPR_CFLAGS%g
s%@NSPR_LIBS@%$NSPR_LIBS%g
s%@NSPR_CONFIG@%$NSPR_CONFIG%g
+s%@PKG_CONFIG@%$PKG_CONFIG%g
+s%@MOZ_FFI_CFLAGS@%$MOZ_FFI_CFLAGS%g
+s%@MOZ_FFI_LIBS@%$MOZ_FFI_LIBS%g
+s%@MOZ_NATIVE_FFI@%$MOZ_NATIVE_FFI%g
s%@MOZ_UI_LOCALE@%$MOZ_UI_LOCALE%g
s%@MOZ_THUMB2@%$MOZ_THUMB2%g
s%@MOZ_ARM_ARCH@%$MOZ_ARM_ARCH%g
s%@MOZ_OPTIMIZE@%$MOZ_OPTIMIZE%g
s%@MOZ_OPTIMIZE_FLAGS@%$MOZ_OPTIMIZE_FLAGS%g
s%@MOZ_OPTIMIZE_LDFLAGS@%$MOZ_OPTIMIZE_LDFLAGS%g
@@ -16121,7 +16235,7 @@ echo "$ac_t""invoking make to create js-
$GMAKE js-config
# Build jsctypes if it's enabled.
-if test "$JS_HAS_CTYPES"; then
+if test "$JS_HAS_CTYPES" -a -z "$MOZ_NATIVE_FFI"; then
# Run the libffi 'configure' script.
ac_configure_args="--disable-shared --enable-static --disable-raw-api"
if test "$MOZ_DEBUG"; then