Shuriken-nix/configuration.nix
2023-07-11 01:02:03 +05:30

113 lines
2.6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ config, pkgs, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
# import home manager.
<home-manager/nixos>
];
# Bootloader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
# Setup keyfile
boot.initrd.secrets = {
"/crypto_keyfile.bin" = null;
};
networking.hostName = "nixos"; # Define your hostname.
# Enable network manager
networking.networkmanager.enable = true;
# Set your time zone.
time.timeZone = "Asia/Kolkata";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
i18n.extraLocaleSettings = {
LC_ADDRESS = "en_IN";
LC_IDENTIFICATION = "en_IN";
LC_MEASUREMENT = "en_IN";
LC_MONETARY = "en_IN";
LC_NAME = "en_IN";
LC_NUMERIC = "en_IN";
LC_PAPER = "en_IN";
LC_TELEPHONE = "en_IN";
LC_TIME = "en_IN";
};
# Enable the X11 windowing system.
services.xserver.enable = true;
# Enable the GNOME Desktop Environment.
services.xserver.displayManager.gdm.enable = true;
services.xserver.desktopManager.gnome.enable = true;
# Configure keymap in X11
services.xserver = {
layout = "us";
xkbVariant = "";
};
# Enable CUPS to print documents.
services.printing.enable = true;
# Enable sound with pipewire.
sound.enable = true;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
services.pipewire = {
enable = true;
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
jack.enable = true;
};
# Define a user account. Don't forget to set a password with passwd.
users.users.shuriken = {
isNormalUser = true;
description = "SHuRiKeN";
extraGroups = [ "networkmanager" "wheel" ];
shell = pkgs.fish; # Set fish as the default shell
};
# Setup home manager
home-manager = {
useGlobalPkgs = true;
useUserPackages = true;
users.shuriken = import ./home.nix;
};
programs.steam.enable = true; # Install steam
programs.fish.enable = true; # Install fish
#Enable Nix User Repository (mainly for firefox extensions)
nixpkgs.config.packageOverrides = pkgs: {
nur = import (builtins.fetchTarball "https://github.com/nix-community/NUR/archive/master.tar.gz") {
inherit pkgs;
};
};
# Enable auto upgrade from the current chanel
system.autoUpgrade.enable = true;
# Allow unfree packages
nixpkgs.config.allowUnfree = true;
# Just as a backup for nvim / certain situations
environment.systemPackages = with pkgs; [
vim
];
# Enable ZRAM swap
zramSwap.enable = true;
# No need to change
system.stateVersion = "23.05";
}