wip: gitea: install page loads

This commit is contained in:
Efraim Flashner 2022-01-09 15:46:11 +02:00
parent 7e9856ebdc
commit 4857bdd5da
Signed by: efraim
GPG key ID: 41AAE7DCCA3D8351
2 changed files with 21 additions and 24 deletions

View file

@ -1,7 +1,16 @@
diff --git a/Makefile b/Makefile
index bf3d93d3c..b6f305270 100644
index bf3d93d3c..48f056189 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ else
DIST := dist
DIST_DIRS := $(DIST)/binaries $(DIST)/release
IMPORT := code.gitea.io/gitea
-export GO111MODULE=on
+export GO111MODULE=off
GO ?= go
SHASUM ?= shasum -a 256
@@ -93,7 +93,7 @@ LDFLAGS := $(LDFLAGS) -X "main.MakeVersion=$(MAKE_VERSION)" -X "main.Version=$(G
LINUX_ARCHS ?= linux/amd64,linux/386,linux/arm-5,linux/arm-6,linux/arm64

View file

@ -660,7 +660,7 @@ transformations, and locale-specific text handling.")
`(#:install-source? #f
#:tests? #f ; Disable tests and start with some manual testing
#:import-path "code.gitea.io/gitea"
;#:build-flags (list "-tags bindata sqlite sqlite_unlock_notify")
;#:build-flags (list "-tags 'bindata sqlite sqlite_unlock_notify'")
#:phases
(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'unpatch-example-shebangs
@ -675,22 +675,11 @@ transformations, and locale-specific text handling.")
(("#!/gnu/store/.*/bin/sh") "#!/bin/sh"))))
(add-before 'build 'prepare-build
(lambda _
(setenv "TAGS" "bindata sqlite sqlite_unlock_notify")
; ))
;(replace 'build
; (lambda _
; (with-directory-excursion "src/code.gitea.io/gitea"
; (substitute* "Makefile"
; (("-mod=vendor") "")
; (("go-check generate") "go-check")
;(("(GO_DIRS := .) vendor(.*)" all first last)
; (string-append first last "\n"))
; )
; (invoke "make" "build")
; (invoke "make" "gitea")
; (invoke "make" "install")
; )
))
(setenv "TAGS" "bindata sqlite sqlite_unlock_notify")))
(replace 'build
(lambda _
(with-directory-excursion "src/code.gitea.io/gitea"
(invoke "make" "build"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@ -709,18 +698,17 @@ transformations, and locale-specific text handling.")
(invoke "make" "test-mysql8")
(invoke "make" "test-pgsql")
))))
;(replace 'install
; (lambda _
; (with-directory-excursion "src/code.gitea.io/gitea"
; (invoke "make" "install"))))
(replace 'install
(lambda _
(with-directory-excursion "src/code.gitea.io/gitea"
(invoke "make" "install"))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs inputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/gitea"))
(git (assoc-ref inputs "git")))
(wrap-program bin
`("PATH" ":" prefix (,(string-append git "/bin")))))))
)))
`("PATH" ":" prefix (,(string-append git "/bin"))))))))))
(native-inputs
(list go-github-com-stretchr-testify
node))