3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: fplll: Correct include files.

* gnu/packages/patches/fplll-std-fenv.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/algebra.scm (fplll): Use patch and move all inputs to
propagated-inputs.
This commit is contained in:
Andreas Enge 2020-09-23 14:14:09 +02:00
parent 82f983da35
commit 049a1714fc
No known key found for this signature in database
GPG key ID: F7D5C9BF765C61E3
3 changed files with 22 additions and 2 deletions

View file

@ -968,6 +968,7 @@ dist_patch_DATA = \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
%D%/packages/patches/fpc-reproducibility.patch \
%D%/packages/patches/fplll-std-fenv.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \

View file

@ -160,14 +160,15 @@ line applications.")
(file-name (git-file-name name version))
(sha256
(base32
"06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))))
"06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))
(patches (search-patches "fplll-std-fenv.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
(propagated-inputs ; header files pulled in by fplll/defs.h
`(("gmp" ,gmp)
("mpfr" ,mpfr)))
(home-page "https://github.com/fplll/fplll")

View file

@ -0,0 +1,18 @@
See https://github.com/fplll/fplll/issues/444
--- fplll-5.3.3-checkout.old/fplll/enum/enumerate_base.h 2020-09-23 13:55:27.833769823 +0200
+++ fplll-5.3.3-checkout/fplll/enum/enumerate_base.h 2020-09-23 13:56:14.313771769 +0200
@@ -127,10 +127,10 @@
int rounding_backup;
void save_rounding()
{
- rounding_backup = std::fegetround();
- std::fesetround(FE_TONEAREST);
+ rounding_backup = fegetround();
+ fesetround(FE_TONEAREST);
}
- void restore_rounding() { std::fesetround(rounding_backup); }
+ void restore_rounding() { fesetround(rounding_backup); }
inline bool next_pos_up()
{