mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: Add rust-wl-clipboard-rs-0.4.
* gnu/packages/crates-io.scm (rust-wl-clipboard-rs-0.4): New variable. * gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch: New file. * gnu/local.mk: Add patch. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
This commit is contained in:
parent
cf42c98929
commit
04cb4fcb5e
2 changed files with 64 additions and 0 deletions
|
@ -61205,6 +61205,44 @@ WebAssembly binary files.")
|
|||
modifications.")
|
||||
(license license:asl2.0)))
|
||||
|
||||
(define-public rust-wl-clipboard-rs-0.4
|
||||
(package
|
||||
(name "rust-wl-clipboard-rs")
|
||||
(version "0.4.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (crate-uri "wl-clipboard-rs" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(patches (search-patches "rust-wl-clipboard-rs-newer-wl.patch"))
|
||||
(sha256
|
||||
(base32 "1252cm67pkrr6ik5ys2cdyfr2zzw6ds7v351i1cmyi94yiv01l13"))))
|
||||
(build-system cargo-build-system)
|
||||
(arguments
|
||||
`(#:skip-build? #t
|
||||
#:cargo-inputs
|
||||
(("rust-derive-new" ,rust-derive-new-0.5)
|
||||
("rust-derive-more" ,rust-derive-more-0.99)
|
||||
("rust-exitfailure" ,rust-exitfailure-0.5)
|
||||
("rust-failure" ,rust-failure-0.1)
|
||||
("rust-libc" ,rust-libc-0.2)
|
||||
("rust-log" ,rust-log-0.4)
|
||||
("rust-mime-guess" ,rust-mime-guess-2)
|
||||
("rust-nix" ,rust-nix-0.18)
|
||||
("rust-os-pipe" ,rust-os-pipe-0.9)
|
||||
("rust-stderrlog" ,rust-stderrlog-0.4)
|
||||
("rust-structopt" ,rust-structopt-0.3)
|
||||
("rust-tempfile" ,rust-tempfile-3)
|
||||
("rust-tree-magic" ,rust-tree-magic-0.2)
|
||||
("rust-wayland-client" ,rust-wayland-client-0.28)
|
||||
("rust-wayland-commons" ,rust-wayland-commons-0.28)
|
||||
("rust-wayland-protocols" ,rust-wayland-protocols-0.28))))
|
||||
(home-page "https://github.com/YaLTeR/wl-clipboard-rs")
|
||||
(synopsis "Access to the Wayland clipboard")
|
||||
(description "This package provides access to the Wayland clipboard
|
||||
for terminal and other window-less applications.")
|
||||
(license (list license:expat license:asl2.0))))
|
||||
|
||||
(define-public rust-web-sys-0.3
|
||||
(package
|
||||
(name "rust-web-sys")
|
||||
|
|
26
gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch
Normal file
26
gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 7b975e0..313cb63 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml.new
|
||||
@@ -75,17 +75,17 @@ version = "3"
|
||||
version = "0.2"
|
||||
|
||||
[dependencies.wayland-client]
|
||||
-version = "0.27"
|
||||
+version = "0.28"
|
||||
|
||||
[dependencies.wayland-protocols]
|
||||
-version = "0.27"
|
||||
+version = "0.28"
|
||||
features = ["client", "unstable_protocols"]
|
||||
[dev-dependencies.wayland-protocols]
|
||||
-version = "0.27"
|
||||
+version = "0.28"
|
||||
features = ["server", "unstable_protocols"]
|
||||
|
||||
[dev-dependencies.wayland-server]
|
||||
-version = "0.27"
|
||||
+version = "0.28"
|
||||
|
||||
[features]
|
||||
dlopen = ["native_lib", "wayland-client/dlopen", "wayland-server/dlopen"]
|
Loading…
Reference in a new issue