3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: glib-networking: Skip failing test.

* gnu/packages/patches/glib-networking-gnutls-binding.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (glib-networking)[source]: Use it.
This commit is contained in:
Ludovic Courtès 2021-07-31 23:42:21 +02:00
parent 9fb7269059
commit 0a1a1ad213
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 25 additions and 1 deletions

View file

@ -1100,6 +1100,7 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
%D%/packages/patches/giara-fix-login.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \
%D%/packages/patches/glib-skip-failing-test.patch \
%D%/packages/patches/glibc-CVE-2018-11236.patch \
%D%/packages/patches/glibc-CVE-2018-11237.patch \

View file

@ -4685,7 +4685,9 @@ library.")
"glib-networking-" version ".tar.xz"))
(sha256
(base32
"0vlzn8jf4sg90cm8xxr28yf66nhf8qy9dl2m4b8w1cr6mn2mw8qb"))))
"0vlzn8jf4sg90cm8xxr28yf66nhf8qy9dl2m4b8w1cr6mn2mw8qb"))
(patches
(search-patches "glib-networking-gnutls-binding.patch"))))
(build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)

View file

@ -0,0 +1,21 @@
Skip failing test in 'test_connection_binding_match_tls_unique'
in 'tls/tests/connection.c' when building glib-networking against
GnuTLS 3.7.2. The failure stems from the fact that
'gnutls_session_channel_binding' returns GNUTLS_E_INVALID_REQUEST
is known upstream:
https://gitlab.gnome.org/GNOME/glib-networking/-/issues/164
diff --git a/tls/tests/connection.c b/tls/tests/connection.c
index 036df04..347c7a4 100644
--- a/tls/tests/connection.c
+++ b/tls/tests/connection.c
@@ -3037,8 +3037,6 @@ main (int argc,
setup_connection, test_connection_missing_server_identity, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/peer-certificate-notify", TestConnection, NULL,
setup_connection, test_peer_certificate_notify, teardown_connection);
- g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-unique", TestConnection, NULL,
- setup_connection, test_connection_binding_match_tls_unique, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-server-end-point", TestConnection, NULL,
setup_connection, test_connection_binding_match_tls_server_end_point, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-exporter", TestConnection, NULL,