mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: knot: Update to 3.0.1.
* gnu/packages/dns.scm (knot): Update to 3.0.1. [source]: Remove patch. * gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
3c452a35ef
commit
0e5968e49a
3 changed files with 2 additions and 24 deletions
|
@ -1198,7 +1198,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/kpackage-allow-external-paths.patch \
|
||||
%D%/packages/patches/kmplayer-aarch64.patch \
|
||||
%D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
|
||||
%D%/packages/patches/knot-test_net_shortwrite-ensure-connection.patch \
|
||||
%D%/packages/patches/kobodeluxe-paths.patch \
|
||||
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
|
||||
%D%/packages/patches/kobodeluxe-const-charp-conversion.patch \
|
||||
|
|
|
@ -807,7 +807,7 @@ Extensions} (DNSSEC).")
|
|||
(define-public knot
|
||||
(package
|
||||
(name "knot")
|
||||
(version "3.0.0")
|
||||
(version "3.0.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -816,9 +816,7 @@ Extensions} (DNSSEC).")
|
|||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0fkvip7n5ihjfwnnivdc3jf44y8p85ifglvq7b0anxvj9cg1m78f"))
|
||||
(patches
|
||||
(search-patches "knot-test_net_shortwrite-ensure-connection.patch"))
|
||||
(base32 "10mlzldxqvbaw78nghkr0s73rlbpz9wg16z14321xw2l9xfibkad"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
This patch duplicates upstream commit 4144d1e, which helps ensure the
|
||||
"test_net_shortwrite" test suite can succeed across all platforms by
|
||||
deepening the pending-connection queue of the server it creates from 0
|
||||
to 1.
|
||||
|
||||
See the original report at
|
||||
https://gitlab.nic.cz/knot/knot-dns/-/issues/693
|
||||
|
||||
--- a/tests/contrib/test_net_shortwrite.c
|
||||
+++ b/tests/contrib/test_net_shortwrite.c
|
||||
@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
|
||||
int server = net_bound_socket(SOCK_STREAM, &addr, 0);
|
||||
ok(server >= 0, "server: bind socket");
|
||||
|
||||
- r = listen(server, 0);
|
||||
+ r = listen(server, 1);
|
||||
ok(r == 0, "server: start listening");
|
||||
|
||||
struct sockaddr *sa = (struct sockaddr *)&addr;
|
Loading…
Reference in a new issue