mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: gtk-doc: Update to 1.33.2.
* gnu/packages/patches/gtk-doc-respect-xml-catalog.patch: New file. * gnu/local.mk (DIST_PATCH_DATA): Add it. * gnu/packages/gtk.scm (gtk-doc): Update to 1.33.2. [source]: Add gtk-doc-respect-xml-catalog.patch patch. [build-system]: Switch to meson. [arguments]: Remove fix-docbook phase. Remove configure flags that are no longer needed. [outputs]: Remove the help output since the help-dir option no longer exists.
This commit is contained in:
parent
b8991c5e1c
commit
100520bab3
3 changed files with 24 additions and 29 deletions
|
@ -1199,6 +1199,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gtk2-theme-paths.patch \
|
||||
%D%/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
|
||||
%D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
|
||||
%D%/packages/patches/gtk-doc-respect-xml-catalog.patch \
|
||||
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
|
||||
%D%/packages/patches/gvfs-add-support-for-libplist-2.2.patch \
|
||||
|
|
|
@ -2047,7 +2047,7 @@ information.")
|
|||
(define-public gtk-doc
|
||||
(package
|
||||
(name "gtk-doc")
|
||||
(version "1.32")
|
||||
(version "1.33.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
|
@ -2055,9 +2055,10 @@ information.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0z4h1dggpimygdp719l457jvqilps4qcfpk31jmj3jqpzcsg03ny"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
(outputs '("out" "help"))
|
||||
"0hxza8qp52lrq7s1vbilz2vh4170cail560zi8khl0zb42d706yc"))
|
||||
(patches
|
||||
(search-patches "gtk-doc-respect-xml-catalog.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:parallel-tests? #f
|
||||
#:phases
|
||||
|
@ -2078,40 +2079,17 @@ information.")
|
|||
#t))
|
||||
(add-after 'unpack 'disable-failing-tests
|
||||
(lambda _
|
||||
(substitute* "tests/Makefile.in"
|
||||
(substitute* "tests/Makefile.am"
|
||||
(("annotations.sh bugs.sh empty.sh fail.sh gobject.sh program.sh")
|
||||
""))
|
||||
#t))
|
||||
(add-before 'configure 'fix-docbook
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "configure"
|
||||
;; The configure check is overzealous about making sure that
|
||||
;; things are in place -- it uses the xmlcatalog tool to make
|
||||
;; sure that docbook-xsl is available, but this tool can only
|
||||
;; look in one catalog file, unlike the $XML_CATALOG_FILES
|
||||
;; variable that Guix defines. Fool the test by using the
|
||||
;; docbook-xsl catalog explicitly and get on with life.
|
||||
(("\"\\$XML_CATALOG_FILE\" \
|
||||
\"http://docbook.sourceforge.net/release/xsl/")
|
||||
(string-append (car (find-files (assoc-ref inputs "docbook-xsl")
|
||||
"^catalog.xml$"))
|
||||
" \"http://docbook.sourceforge.net/release/xsl/")))
|
||||
#t))
|
||||
(add-after 'install 'wrap-executables
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
(for-each (lambda (prog)
|
||||
(wrap-program prog
|
||||
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))
|
||||
(find-files (string-append out "/bin")))
|
||||
#t))))
|
||||
#:configure-flags
|
||||
(list (string-append "--with-xml-catalog="
|
||||
(assoc-ref %build-inputs "docbook-xml")
|
||||
"/xml/dtd/docbook/catalog.xml")
|
||||
(string-append "--with-help-dir="
|
||||
(assoc-ref %outputs "help")
|
||||
"/share/help"))))
|
||||
(find-files (string-append out "/bin")))))))))
|
||||
(native-inputs
|
||||
`(("gettext" ,gettext-minimal)
|
||||
("glib:bin" ,glib "bin")
|
||||
|
|
16
gnu/packages/patches/gtk-doc-respect-xml-catalog.patch
Normal file
16
gnu/packages/patches/gtk-doc-respect-xml-catalog.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
Taken from here:
|
||||
https://github.com/NixOS/nixpkgs/blob/master/pkgs/development/tools/documentation/gtk-doc/respect-xml-catalog-files-var.patch.
|
||||
|
||||
--- a/m4/gtkdoc_jh_check_xml_catalog.m4
|
||||
+++ b/m4/gtkdoc_jh_check_xml_catalog.m4
|
||||
@@ -5,8 +5,8 @@
|
||||
[
|
||||
AC_REQUIRE([JH_PATH_XML_CATALOG],[JH_PATH_XML_CATALOG(,[:])])dnl
|
||||
AC_MSG_CHECKING([for ifelse([$2],,[$1],[$2]) in XML catalog])
|
||||
- if $jh_found_xmlcatalog && \
|
||||
- AC_RUN_LOG([$XMLCATALOG --noout "$XML_CATALOG_FILE" "$1" >&2]); then
|
||||
+ # empty argument forces libxml to use XML_CATALOG_FILES variable
|
||||
+ if AC_RUN_LOG([$XMLCATALOG --noout "" "$1" >&2]); then
|
||||
AC_MSG_RESULT([found])
|
||||
ifelse([$3],,,[$3])
|
||||
else
|
Loading…
Reference in a new issue