mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: restic: Patch tests for go-1.16.
* gnu/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/backup.scm (restic): Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
This commit is contained in:
parent
733ca63bcd
commit
1273548f4f
3 changed files with 56 additions and 1 deletions
|
@ -1693,6 +1693,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/rtags-separate-rct.patch \
|
||||
%D%/packages/patches/racket-minimal-sh-via-rktio.patch \
|
||||
%D%/packages/patches/remake-impure-dirs.patch \
|
||||
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \
|
||||
%D%/packages/patches/retroarch-LIBRETRO_DIRECTORY.patch \
|
||||
%D%/packages/patches/rnp-add-version.cmake.patch \
|
||||
%D%/packages/patches/rnp-disable-ruby-rnp-tests.patch \
|
||||
|
|
|
@ -20,6 +20,7 @@
|
|||
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
|
||||
;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
|
||||
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
|
||||
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -928,7 +929,9 @@ is like a time machine for your data. ")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1zmh42aah32ah8w5n6ilz9bci0y2xrf8p7qshy3yf1lzm5gnbj0w"))))
|
||||
"1zmh42aah32ah8w5n6ilz9bci0y2xrf8p7qshy3yf1lzm5gnbj0w"))
|
||||
(patches
|
||||
(search-patches "restic-0.9.6-fix-tests-for-go1.15.patch"))))
|
||||
(build-system go-build-system)
|
||||
(arguments
|
||||
`(#:import-path "github.com/restic/restic"
|
||||
|
|
51
gnu/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch
Normal file
51
gnu/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
This cherry-picked patch fixes tests for Go >= 1.15. Restic v0.10 (which
|
||||
includes this patch) requires go module support from the Go build system.
|
||||
Original patch follows.
|
||||
|
||||
---
|
||||
From 97950ab81a18de06b95384da6d8646fef87c9d97 Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Neumann <alexander@bumpern.de>
|
||||
Date: Sat, 12 Sep 2020 17:36:44 +0200
|
||||
Subject: [PATCH] options: Fix test for Go >= 1.15
|
||||
|
||||
---
|
||||
internal/options/options_test.go | 12 +++++++++---
|
||||
1 file changed, 9 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/internal/options/options_test.go b/internal/options/options_test.go
|
||||
index de94fc90a1..8d268992a3 100644
|
||||
--- a/internal/options/options_test.go
|
||||
+++ b/internal/options/options_test.go
|
||||
@@ -3,6 +3,7 @@ package options
|
||||
import (
|
||||
"fmt"
|
||||
"reflect"
|
||||
+ "regexp"
|
||||
"testing"
|
||||
"time"
|
||||
)
|
||||
@@ -199,7 +200,7 @@ var invalidSetTests = []struct {
|
||||
"timeout": "2134",
|
||||
},
|
||||
"ns",
|
||||
- `time: missing unit in duration 2134`,
|
||||
+ `time: missing unit in duration "?2134"?`,
|
||||
},
|
||||
}
|
||||
|
||||
@@ -212,8 +213,13 @@ func TestOptionsApplyInvalid(t *testing.T) {
|
||||
t.Fatalf("expected error %v not found", test.err)
|
||||
}
|
||||
|
||||
- if err.Error() != test.err {
|
||||
- t.Fatalf("expected error %q, got %q", test.err, err.Error())
|
||||
+ matched, err := regexp.MatchString(test.err, err.Error())
|
||||
+ if err != nil {
|
||||
+ t.Fatal(err)
|
||||
+ }
|
||||
+
|
||||
+ if !matched {
|
||||
+ t.Fatalf("expected error to match %q, got %q", test.err, err.Error())
|
||||
}
|
||||
})
|
||||
}
|
Loading…
Reference in a new issue