gnu: xpra: Update to 4.0.5.

* gnu/packages/xorg.scm (xpra): Update to 4.0.5.
[source]: Remove xpra-4.0.4-norequests.patch.
* gnu/packages/patches/xpra-4.0.4-norequests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Tobias Geerinckx-Rice 2020-11-20 20:47:19 +01:00
parent c92ec09580
commit 155e3c775a
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 3 additions and 44 deletions

View File

@ -1724,7 +1724,6 @@ dist_patch_DATA = \
%D%/packages/patches/xplanet-1.3.1-libimage_gif.c.patch \
%D%/packages/patches/xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch \
%D%/packages/patches/xpra-4.0.1-systemd-run.patch \
%D%/packages/patches/xpra-4.0.4-norequests.patch \
%D%/packages/patches/xsane-fix-memory-leak.patch \
%D%/packages/patches/xsane-fix-pdf-floats.patch \
%D%/packages/patches/xsane-fix-snprintf-buffer-length.patch \

View File

@ -1,39 +0,0 @@
Remove python-requests dependency, r27626 upstream.
--- a/xpra/net/websockets/common.py (revision 27625)
+++ b/xpra/net/websockets/common.py (revision 27626)
@@ -7,7 +7,6 @@
import uuid
from hashlib import sha1
from base64 import b64encode
-from requests.structures import CaseInsensitiveDict
from xpra.os_util import strtobytes, bytestostr, monotonic_time
from xpra.log import Logger
@@ -77,7 +76,7 @@
for line in lines:
parts = line.split(b": ", 1)
if len(parts)==2:
- headers[parts[0]] = parts[1]
+ headers[parts[0].lower()] = parts[1]
return headers
def verify_response_headers(headers, key):
@@ -84,14 +83,13 @@
log("verify_response_headers(%s)", headers)
if not headers:
raise Exception("no http headers found in response")
- headers = CaseInsensitiveDict(headers)
- upgrade = headers.get(b"Upgrade", b"")
+ upgrade = headers.get(b"upgrade", b"")
if upgrade!=b"websocket":
raise Exception("invalid http upgrade: '%s'" % upgrade)
- protocol = headers.get(b"Sec-WebSocket-Protocol", b"")
+ protocol = headers.get(b"sec-websocket-protocol", b"")
if protocol!=b"binary":
raise Exception("invalid websocket protocol: '%s'" % protocol)
- accept_key = headers.get(b"Sec-WebSocket-Accept", b"")
+ accept_key = headers.get(b"sec-websocket-accept", b"")
if not accept_key:
raise Exception("websocket accept key is missing")
expected_key = make_websocket_accept_hash(key)

View File

@ -6304,16 +6304,15 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
(version "4.0.4")
(version "4.0.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.xpra.org/src/xpra-"
version ".tar.xz"))
(sha256
(base32 "10alqdfmgml9ixdi1nyd9xlw8a5q0j8m2sv4g9p83pd6z1a0rpv2"))
(patches (search-patches "xpra-4.0.1-systemd-run.patch"
"xpra-4.0.4-norequests.patch"))))
(base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
(patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
(build-system python-build-system)
;; see also http://xpra.org/trac/wiki/Dependencies
(inputs `(