mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: kde-frameworks: Update to 5.63.0.
KHolidays is part of frameworks since version 5.43 already. * gnu/packages/kde.scm(kholidays): Move to … * gnu/packages/kde-frameworks.scm(kholidays) … here, update to 5.63.0 and [source]: Update path. (attica, baloo, bluez-qt, breeze- icons, extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive, kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kcoreaddons, kcrash, kdbusaddons, kde-frameworkintegration, kdeclarative, kded, kdelibs4support, kdesu, kdnssd, kdoctools, kemoticons, kglobalaccel, kguiaddons, khtml, ki18n, kidletime, kimageformats, kinit, kirigami, kitemmodels, kitemviews, kjobwidgets, kjs, kjsembed, kmediaplayer, knewstuff, knotifications, knotifyconfig, kpackage, kparts, kpeople, kpty, kross, krunner, kservice, ksyntaxhighlighting, ktexteditor, kunitconversion, kwallet, kwidgetsaddons, kxmlrpcclient, modemmanager-qt, networkmanager-qt, oxygen-icons, plasma-framework, prison, qqc2-desktop-style, solid, sonnet, threadweaver): Update to 5.63.0. (kconfigwidgets): Update to 5.63.0; [inputs]: Add qttools. (kdesignerplugin): Update to 5.63.0; [source]: Update path. (kdewebkit): Update to 5.63.0; [source]: Update path.; [inputs]: Add qttools. (kfilemetadata): Update to 5.63.0; [inputs]: Add kcoreaddons; [arguments]<#pahses>: Add a test-case to the blacklist (kiconthemes): Update to 5.63.0; [inputs]: Add qttools. (kio): Update to 5.63.0; [inputs]: Add qttools. (kplotting): Update to 5.63.0; [inputs]: Add qttools. (ktextwidgets): Update to 5.63.0; [inputs]: Add qttools. (kwayland): Update to 5.63.0; [inputs]: Add wayland-protocols. (kwindowsystem): Update to 5.63.0, update blacklist or tests, explicitly set XDG_RUNTIME_DIR; [inputs]: Add xcb-util-wm. (kxmlgui): Update to 5.63.0; [inputs]: Add qttools. * gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Adjust. * gnu/packages/patches/kwindowsystem-qt-compat.patch: Remove obsolete patch.
This commit is contained in:
parent
a1cbeb7b10
commit
1dd1076c5e
4 changed files with 209 additions and 297 deletions
File diff suppressed because it is too large
Load diff
|
@ -407,41 +407,6 @@ illustrators, matte and texture artists, and the VFX industry. Notable
|
|||
features include brush stabilizers, brush engines and wrap-around mode.")
|
||||
(license license:gpl2+)))
|
||||
|
||||
(define-public kholidays
|
||||
(package
|
||||
(name "kholidays")
|
||||
(version "17.12.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://kde/stable/applications/" version "/src/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0595d7wbnz8kyq1bnivdrp20lwdp8ykvdll1fmb0fgm4q24z0cl8"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'check 'check-setup
|
||||
(lambda _
|
||||
;; blacklist a failing test function TODO: make it pass
|
||||
(with-output-to-file "autotests/BLACKLIST"
|
||||
(lambda _
|
||||
(display "[testDefaultRegions]\n*\n")))
|
||||
#t)))))
|
||||
(native-inputs
|
||||
`(("extra-cmake-modules" ,extra-cmake-modules)
|
||||
("qttools" ,qttools)))
|
||||
(inputs
|
||||
`(("qtbase" ,qtbase)
|
||||
("qtdeclarative" ,qtdeclarative)))
|
||||
(home-page "https://cgit.kde.org/kholidays.git")
|
||||
(synopsis "Library for regional holiday information")
|
||||
(description "This library provides a C++ API that determines holiday and
|
||||
other special events for a geographical region.")
|
||||
(license license:lgpl2.0+)))
|
||||
|
||||
(define-public libkomparediff2
|
||||
(package
|
||||
(name "libkomparediff2")
|
||||
|
|
|
@ -8,15 +8,13 @@ pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
|
|||
===================================================================
|
||||
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
|
||||
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
|
||||
@@ -96,11 +96,9 @@
|
||||
@@ -96,9 +96,9 @@
|
||||
"libKF5Parts.5.dylib",
|
||||
"libKF5Plasma.5.dylib"
|
||||
#else
|
||||
- "libKF5KIOCore.so.5",
|
||||
- "libKF5Parts.so.5",
|
||||
-//#ifdef __KDE_HAVE_GCC_VISIBILITY // Removed for KF5, we'll see.
|
||||
- "libKF5Plasma.so.5"
|
||||
-//#endif
|
||||
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
|
||||
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
|
||||
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
|
||||
|
|
|
@ -1,97 +0,0 @@
|
|||
Fix test failure with Qt 5.12.
|
||||
|
||||
Taken from upstream:
|
||||
https://cgit.kde.org/kwindowsystem.git/commit/?id=14998613603c7d8f91b011a2c9c20396067add0e
|
||||
|
||||
diff --git a/autotests/CMakeLists.txt b/autotests/CMakeLists.txt
|
||||
index f8e67f0..c1121a7 100644
|
||||
--- a/autotests/CMakeLists.txt
|
||||
+++ b/autotests/CMakeLists.txt
|
||||
@@ -12,12 +12,12 @@ add_subdirectory(helper)
|
||||
|
||||
if (NOT APPLE)
|
||||
find_package(X11)
|
||||
- find_package(XCB COMPONENTS XCB KEYSYMS)
|
||||
+ find_package(XCB COMPONENTS XCB ICCCM KEYSYMS)
|
||||
endif()
|
||||
|
||||
macro(KWINDOWSYSTEM_UNIT_TESTS)
|
||||
foreach(_testname ${ARGN})
|
||||
- set(libs KF5::WindowSystem Qt5::Test Qt5::Widgets Qt5::X11Extras XCB::KEYSYMS)
|
||||
+ set(libs KF5::WindowSystem Qt5::Test Qt5::Widgets Qt5::X11Extras XCB::ICCCM XCB::KEYSYMS)
|
||||
if(X11_FOUND)
|
||||
list(APPEND libs ${XCB_XCB_LIBRARY})
|
||||
endif()
|
||||
diff --git a/autotests/kwindowinfox11test.cpp b/autotests/kwindowinfox11test.cpp
|
||||
index 634c650..f483c46 100644
|
||||
--- a/autotests/kwindowinfox11test.cpp
|
||||
+++ b/autotests/kwindowinfox11test.cpp
|
||||
@@ -25,8 +25,11 @@
|
||||
#include <qtest_widgets.h>
|
||||
#include <QScreen>
|
||||
#include <QSignalSpy>
|
||||
+#include <QSysInfo>
|
||||
#include <QX11Info>
|
||||
|
||||
+#include <xcb/xcb_icccm.h>
|
||||
+
|
||||
#include <unistd.h>
|
||||
|
||||
Q_DECLARE_METATYPE(WId)
|
||||
@@ -598,19 +601,23 @@ void KWindowInfoX11Test::testWindowRole()
|
||||
|
||||
void KWindowInfoX11Test::testClientMachine()
|
||||
{
|
||||
+ const QByteArray oldHostName = QSysInfo::machineHostName().toLocal8Bit();
|
||||
+
|
||||
KWindowInfo info(window->winId(), NET::Properties(), NET::WM2ClientMachine);
|
||||
- QVERIFY(info.clientMachine().isNull());
|
||||
+ QCOMPARE(info.clientMachine(), oldHostName);
|
||||
|
||||
// client machine needs to be set through xcb
|
||||
+ const QByteArray newHostName = oldHostName + "2";
|
||||
xcb_change_property(QX11Info::connection(), XCB_PROP_MODE_REPLACE, window->winId(),
|
||||
- XCB_ATOM_WM_CLIENT_MACHINE, XCB_ATOM_STRING, 8, 9, "localhost");
|
||||
+ XCB_ATOM_WM_CLIENT_MACHINE, XCB_ATOM_STRING, 8, newHostName.count(),
|
||||
+ newHostName.data());
|
||||
xcb_flush(QX11Info::connection());
|
||||
|
||||
// it's just a property change so we can easily refresh
|
||||
QX11Info::getTimestamp();
|
||||
|
||||
KWindowInfo info2(window->winId(), NET::Properties(), NET::WM2ClientMachine);
|
||||
- QCOMPARE(info2.clientMachine(), QByteArrayLiteral("localhost"));
|
||||
+ QCOMPARE(info2.clientMachine(), newHostName);
|
||||
}
|
||||
|
||||
void KWindowInfoX11Test::testName()
|
||||
@@ -680,11 +687,25 @@ void KWindowInfoX11Test::testTransientFor()
|
||||
|
||||
void KWindowInfoX11Test::testGroupLeader()
|
||||
{
|
||||
- KWindowInfo info(window->winId(), NET::Properties(), NET::WM2GroupLeader);
|
||||
- QCOMPARE(info.groupLeader(), WId(0));
|
||||
+ // WM_CLIENT_LEADER is set by default
|
||||
+ KWindowInfo info1(window->winId(), NET::Properties(), NET::WM2GroupLeader);
|
||||
+ QVERIFY(info1.groupLeader() != XCB_WINDOW_NONE);
|
||||
+
|
||||
+ xcb_connection_t *connection = QX11Info::connection();
|
||||
+ xcb_window_t rootWindow = QX11Info::appRootWindow();
|
||||
+
|
||||
+ xcb_window_t leader = xcb_generate_id(connection);
|
||||
+ xcb_create_window(connection, XCB_COPY_FROM_PARENT, leader, rootWindow, 0, 0, 1, 1,
|
||||
+ 0, XCB_WINDOW_CLASS_INPUT_OUTPUT, XCB_COPY_FROM_PARENT, 0, nullptr);
|
||||
+
|
||||
+ xcb_icccm_wm_hints_t hints = {};
|
||||
+ hints.flags = XCB_ICCCM_WM_HINT_WINDOW_GROUP;
|
||||
+ hints.window_group = leader;
|
||||
+ xcb_icccm_set_wm_hints(connection, leader, &hints);
|
||||
+ xcb_icccm_set_wm_hints(connection, window->winId(), &hints);
|
||||
|
||||
- // TODO: here we should try to set a group leader and re-read it
|
||||
- // this needs setting and parsing the WMHints
|
||||
+ KWindowInfo info2(window->winId(), NET::Properties(), NET::WM2GroupLeader);
|
||||
+ QCOMPARE(info2.groupLeader(), leader);
|
||||
}
|
||||
|
||||
void KWindowInfoX11Test::testExtendedStrut()
|
Loading…
Reference in a new issue