3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

chez-sheme-for-racket: Fix building on riscv64-linux.

* gnu/packages/racket.scm (%racket-origin): Add patch.
* gnu/packages/patches/racket-rktboot-riscv64-support.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
Efraim Flashner 2023-07-19 21:04:26 +03:00
parent 182be30fb1
commit 261422e745
Signed by untrusted user: efraim
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 17 additions and 0 deletions

View file

@ -1882,6 +1882,7 @@ dist_patch_DATA = \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
%D%/packages/patches/rtags-separate-rct.patch \
%D%/packages/patches/racket-chez-scheme-bin-sh.patch \
%D%/packages/patches/racket-rktboot-riscv64-support.patch \
%D%/packages/patches/racket-rktio-bin-sh.patch \
%D%/packages/patches/racket-zuo-bin-sh.patch \
%D%/packages/patches/remake-impure-dirs.patch \

View file

@ -0,0 +1,15 @@
Submitted upstream:
https://github.com/racket/racket/pull/4703
diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
index 8ff0688..59ebfc8 100644
--- a/racket/src/rktboot/machine-def.rkt
+++ b/racket/src/rktboot/machine-def.rkt
@@ -25,6 +25,7 @@
[(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
[(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
[(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
+ [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
[(regexp-match? #rx"^t?pb" target-machine) "pb"]
[else (error "machine.def: cannot infer architecture")]))]
[s (regexp-replace* #rx"[$][(]Mend[)]" s

View file

@ -204,6 +204,7 @@
(base32 "120djvscm2x1nv46is0kzwahd22rcc8gc0ssf12jnj7w290dpmra"))
(file-name (git-file-name "racket" %racket-version))
(patches (search-patches "racket-chez-scheme-bin-sh.patch"
"racket-rktboot-riscv64-support.patch"
"racket-rktio-bin-sh.patch"
"racket-zuo-bin-sh.patch"))
(modules '((guix build utils)))