gnu: Add aws-c-mqtt.

* gnu/packages/c.scm (aws-c-mqtt): New variable.
* gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-04-30 14:02:44 +00:00 committed by Ludovic Courtès
parent b3c1c37d74
commit 2a0fcc31f7
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 42 additions and 0 deletions

View File

@ -876,6 +876,7 @@ dist_patch_DATA = \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-disable-networking-tests.patch\
%D%/packages/patches/aws-c-mqtt-cmake-prefix.patch \
%D%/packages/patches/aws-c-io-cmake-prefix.patch \
%D%/packages/patches/aws-c-io-disable-networking-tests.patch \
%D%/packages/patches/aws-c-s3-cmake-prefix.patch \

View File

@ -834,3 +834,31 @@ authentication.")
Service (S3) protocol for object storage.")
(home-page "https://github.com/awslabs/aws-c-s3")
(license license:asl2.0)))
(define-public aws-c-mqtt
(package
(name "aws-c-mqtt")
(version "0.7.6")
(source (origin
(method git-fetch)
(uri (git-reference
(url (string-append "https://github.com/awslabs/" name))
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0qgblakp9n281z5w1kmmy9sjiz6s44kg487l76w7p43p1dp7s401"))
(patches (search-patches "aws-c-mqtt-cmake-prefix.patch"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(propagated-inputs
`(("aws-c-http" ,aws-c-http)
("aws-c-io" ,aws-c-io)))
(synopsis "Amazon Web Services MQTT library")
(description
"This library provides a C99 implementation of the Message Queuing
Telemetry Transport (MQTT) publish-subscribe messaging protocol.")
(home-page "https://github.com/awslabs/aws-c-mqtt")
(license license:asl2.0)))

View File

@ -0,0 +1,13 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,10 @@ if (POLICY CMP0069)
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
endif()
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()