3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: cool-retro-term: Fix build with gcc@10.

* gnu/packages/patches/cool-retro-term-wctype.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/terminals.scm (cool-retro-term)[source]: Add
'cool-retro-term-wctype.patch'.
This commit is contained in:
Eric Bavier 2021-12-27 22:53:46 -06:00
parent d435402e84
commit 2c451db39a
No known key found for this signature in database
GPG key ID: BC45CA67E2F8D007
3 changed files with 16 additions and 1 deletions

View file

@ -962,6 +962,7 @@ dist_patch_DATA = \
%D%/packages/patches/collectd-5.11.0-noinstallvar.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
%D%/packages/patches/cool-retro-term-wctype.patch \
%D%/packages/patches/coreutils-gnulib-tests.patch \
%D%/packages/patches/coq-fix-envvars.patch \
%D%/packages/patches/coreutils-ls.patch \

View file

@ -0,0 +1,13 @@
Submitted upstream at https://github.com/Swordfish90/cool-retro-term/issues/692
--- a/qmltermwidget/lib/TerminalCharacterDecoder.cpp 1969-12-31 18:00:01.000000000 -0600
+++ b/qmltermwidget/lib/TerminalCharacterDecoder.cpp 2021-12-27 22:07:04.452256118 -0600
@@ -19,6 +19,8 @@
02110-1301 USA.
*/
+#include <cwctype>
+
// Own
#include "TerminalCharacterDecoder.h"

View file

@ -13,7 +13,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018, 2019, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
@ -673,6 +673,7 @@ embedded kernel situations.")
(srfi srfi-26)
(ice-9 rdelim)
(ice-9 regex)))
(patches (search-patches "cool-retro-term-wctype.patch"))
(snippet
'(let* ((fonts '(;"1971-ibm-3278" ; BSD 3-clause
"1977-apple2" ; Non-Free