3
4
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: glib: Update to 2.56.0.

* gnu/packages/glib.scm (glib): Update to 2.56.0.
[source](patches): Remove obsolete patch.
[arguments]: Disable new MIME test.
* gnu/packages/patches/glib-respect-datadir.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Marius Bakke 2018-03-14 23:38:29 +01:00
parent f74181d40f
commit 2f437b22e2
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 4 additions and 26 deletions

View file

@ -705,7 +705,6 @@ dist_patch_DATA = \
%D%/packages/patches/gimp-CVE-2017-17787.patch \
%D%/packages/patches/gimp-CVE-2017-17789.patch \
%D%/packages/patches/glib-networking-ssl-cert-file.patch \
%D%/packages/patches/glib-respect-datadir.patch \
%D%/packages/patches/glib-tests-timer.patch \
%D%/packages/patches/glibc-CVE-2015-5180.patch \
%D%/packages/patches/glibc-CVE-2015-7547.patch \

View file

@ -148,7 +148,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
(version "2.54.3")
(version "2.56.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@ -156,9 +156,8 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
"1a60p9m493mvm42rskg8ifr0jmsbr8arzyqx73jshgfwhmkdqgwn"))
(patches (search-patches "glib-respect-datadir.patch"
"glib-tests-timer.patch"))))
"1iqgi90fmpl3l23jm2iv44qp7hqsxvnv7978s18933bvx4bnxvzc"))
(patches (search-patches "glib-tests-timer.patch"))))
(build-system gnu-build-system)
(outputs '("out" ; everything
"bin" ; glib-mkenums, gtester, etc.; depends on Python
@ -235,6 +234,7 @@ shared NFS home directories.")
("gio/tests/contenttype.c"
(;; XXX: requires shared-mime-info.
"/contenttype/guess"
"/contenttype/guess_svg_from_data"
"/contenttype/subtype"
"/contenttype/list"
"/contenttype/icon"

View file

@ -1,21 +0,0 @@
On Guix, Python modules are in a different output from the executables,
so searching "../share/glib-2.0" will not work.
This patch restores behaviour prior to this commit:
<https://git.gnome.org/browse/glib/commit/?id=fe2a9887a8ccb14f2386e01b14834e97a33bc2d7>
--- a/gio/gdbus-2.0/codegen/gdbus-codegen.in
+++ b/gio/gdbus-2.0/codegen/gdbus-codegen.in
@@ -25,9 +25,12 @@
srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)
filedir = os.path.dirname(__file__)
+datadir = os.path.join('@datadir@', 'glib-2.0')
if srcdir is not None:
path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
+elif os.path.exists(os.path.join(datadir, 'codegen')):
+ path = datadir
elif os.path.basename(filedir) == 'bin':
# Make the prefix containing gdbus-codegen 'relocatable' at runtime by
# adding /some/prefix/bin/../share/glib-2.0 to the python path