3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: gdbm: Fix build with GCC 10.

* gnu/packages/patches/gdbm-gcc-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/dbm.scm (gdbm)[source](patches): New field.
This commit is contained in:
Marius Bakke 2020-12-15 23:10:29 +01:00
parent 04496dc574
commit 420ddd0a91
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 18 additions and 0 deletions

View file

@ -1044,6 +1044,7 @@ dist_patch_DATA = \
%D%/packages/patches/gdb-hurd.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-brect-bounds.patch \
%D%/packages/patches/gdbm-gcc-compat.patch \
%D%/packages/patches/gdm-default-session.patch \
%D%/packages/patches/genimage-signedness.patch \
%D%/packages/patches/geoclue-config.patch \

View file

@ -139,6 +139,7 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(method url-fetch)
(uri (string-append "mirror://gnu/gdbm/gdbm-"
version ".tar.gz"))
(patches (search-patches "gdbm-gcc-compat.patch"))
(sha256
(base32
"1p4ibds6z3ccy65lkmd6lm7js0kwifvl53r0fd759fjxgr917rl6"))))

View file

@ -0,0 +1,16 @@
Fix build failure with GCC 10 due to duplicate definitions. It can be
reproduced on older compilers with -fno-common.
Fix taken from Gentoo: https://bugs.gentoo.org/705898
--- a/src/parseopt.c
+++ b/src/parseopt.c
@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
}
char *parseopt_program_name;
-char *parseopt_program_doc;
-char *parseopt_program_args;
const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
void (*parseopt_help_hook) (FILE *stream);