3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: emacs-helpful: Update to 0.19

* gnu/packages/patches/emacs-helpful-docstring-test.patch: New file.
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19.
[source]: Use the patch.
* gnu/local.mk (dist_patch_DATA): Register the patch.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
This commit is contained in:
yarl baudig 2022-05-30 09:20:24 +02:00 committed by Liliana Marie Prikler
parent b8fc3403d3
commit 6169c582d1
No known key found for this signature in database
GPG key ID: 442A84B8C70E2F87
3 changed files with 23 additions and 2 deletions

View file

@ -1028,6 +1028,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-git-email-missing-parens.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \

View file

@ -20130,7 +20130,7 @@ downloading manager for Emacs.")
(define-public emacs-helpful
(package
(name "emacs-helpful")
(version "0.18")
(version "0.19")
(source
(origin
(method git-fetch)
@ -20139,7 +20139,9 @@ downloading manager for Emacs.")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "0gdjxykqkal2x765mi51m99i5ql23i1fy909wy4mzj5ajhjfgqcc"))))
(base32 "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))
;; Cherry-picked from upstream, remove when bumping to 0.20.
(patches (search-patches "emacs-helpful-fix-docstring-test.patch"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))

View file

@ -0,0 +1,18 @@
This patch fixing a build failure has been cherry-picked from upstream.
Originally submitted as pull request by Erik Šabič.
See also <https://github.com/Wilfred/helpful/pull/296>.
diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
index a07aa8e..8a95129 100644
--- a/test/helpful-unit-test.el
+++ b/test/helpful-unit-test.el
@@ -119,7 +119,9 @@ bar")))
(should
(equal
(helpful--docstring #'test-foo-advised t)
- "Docstring here too.")))
+ (if (version< emacs-version "28")
+ "Docstring here too."
+ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
(defun test-foo-no-docstring ()
nil)