3
4
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: telepathy-glib: Fix test failure.

* gnu/packages/patches/telepathy-glib-channel-memory-leak.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/glib.scm (telepathy-glib)[source](patches): Add it.
This commit is contained in:
Marius Bakke 2020-02-15 16:01:01 +01:00
parent fedce7b2b4
commit 6457ae1339
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 21 additions and 0 deletions

View file

@ -1435,6 +1435,7 @@ dist_patch_DATA = \
%D%/packages/patches/texinfo-5-perl-compat.patch \
%D%/packages/patches/texlive-bin-poppler-0.83.patch \
%D%/packages/patches/telegram-purple-adjust-test.patch \
%D%/packages/patches/telepathy-glib-channel-memory-leak.patch \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
%D%/packages/patches/thefuck-test-environ.patch \

View file

@ -805,6 +805,7 @@ up the Gnome environment, and are used in many unrelated projects.")
"1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
(patches
(list
(search-patch "telepathy-glib-channel-memory-leak.patch")
;; Don't use the same test name for multiple tests.
;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
(origin

View file

@ -0,0 +1,19 @@
Prevent a memory leak in call-channel, which otherwise would cause a
test failure in file-transfer-channel.c.
Taken from upstream:
https://gitlab.freedesktop.org/telepathy/telepathy-glib/commit/2e8b2cc0db09b781d99e3755bb6d01548037fe7b
diff --git a/telepathy-glib/call-channel.c b/telepathy-glib/call-channel.c
index 8ed76323be32f83c5f4d6045a50bc1698d8093fd..2a1fa203d4be9f0c8b99344225f4ba9900666ffc 100644
--- a/telepathy-glib/call-channel.c
+++ b/telepathy-glib/call-channel.c
@@ -525,6 +525,8 @@ update_call_members (TpCallChannel *self,
_tp_channel_contacts_queue_prepare_async ((TpChannel *) self,
contacts, update_call_members_prepared_cb, data);
+
+ g_ptr_array_unref (contacts);
}
static void