3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: python-rarfile: Update to 2.8.

* gnu/packages/python.scm (python-rarfile, python2-rarfile): Update to 2.8.
[source]: Remove obsolete patch.
* gnu/packages/patches/python-rarfile-fix-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Leo Famulari 2016-11-27 00:19:21 -05:00
parent 8c4964dd51
commit 6782444764
No known key found for this signature in database
GPG key ID: 2646FA30BACA7F08
3 changed files with 2 additions and 19 deletions

View file

@ -827,7 +827,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-file-double-encoding-bug.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \
%D%/packages/patches/python-rarfile-fix-tests.patch \
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
%D%/packages/patches/python-statsmodels-fix-tests.patch \
%D%/packages/patches/python-configobj-setuptools.patch \

View file

@ -1,14 +0,0 @@
There is no test.sh, but there are test1.sh and test2.sh.
diff --git a/test/Makefile b/test/Makefile
index 027bc5f..5383db3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,5 +1,6 @@
test:
- ./test.sh
+ ./test1.sh
+ ./test2.sh
clean:
rm -rf __pycache__

View file

@ -9816,15 +9816,13 @@ module, adding support for Unicode strings.")
(define-public python-rarfile
(package
(name "python-rarfile")
(version "2.7")
(version "2.8")
(source (origin
(method url-fetch)
(uri (pypi-uri "rarfile" version))
(sha256
(base32
"0d8n1dlpiz7av8dmbp0vclrwl9cnxizr4f2c9xvj1h5nvn480527"))
;; https://github.com/markokr/rarfile/pull/17/
(patches (search-patches "python-rarfile-fix-tests.patch"))))
"0qfad483kcbga0bn4qmcz953xjk16r52fahiy46zzn56v80y89ra"))))
(build-system python-build-system)
(arguments
'(#:phases