3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: openmpi: Increase priority of the PSM component.

* gnu/packages/patches/openmpi-psm2-priority.patch: Rename to...
* gnu/packages/patches/openmpi-mtl-priorities.patch: ... this.  Add hunk
to change the priority of PSM.
* gnu/packages/mpi.scm (openmpi)[source]: Adjust accordingly.
* gnu/local.mk (dist_patch_DATA): Likewise.
This commit is contained in:
Ludovic Courtès 2019-11-29 13:51:50 +01:00
parent f02fc042a4
commit 68ac34e120
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 16 additions and 2 deletions

View file

@ -1203,7 +1203,7 @@ dist_patch_DATA = \
%D%/packages/patches/opencv-rgbd-aarch64-test-fix.patch \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
%D%/packages/patches/openmpi-psm2-priority.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \
%D%/packages/patches/openocd-nrf52.patch \
%D%/packages/patches/opensmtpd-fix-crash.patch \
%D%/packages/patches/openssl-runpath.patch \

View file

@ -179,7 +179,7 @@ bind processes, and much more.")
"/downloads/openmpi-" version ".tar.bz2"))
(sha256
(base32 "0ms0zvyxyy3pnx9qwib6zaljyp2b3ixny64xvq3czv3jpr8zf2wh"))
(patches (search-patches "openmpi-psm2-priority.patch"))))
(patches (search-patches "openmpi-mtl-priorities.patch"))))
(build-system gnu-build-system)
(inputs
`(("hwloc" ,hwloc-2 "lib")

View file

@ -19,3 +19,17 @@ See <https://www.mail-archive.com/users@lists.open-mpi.org/msg33581.html>.
"priority", "Priority of the PSM2 MTL component",
MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,
Likewise for PSM: we want InfiniPath to be taken care of by PSM, not by UCX,
since UCX achieves worse performance.
--- openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
+++ openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
@@ -92,7 +92,7 @@ ompi_mtl_psm_component_register(void)
/* set priority high enough to beat ob1's default */
- param_priority = 30;
+ param_priority = 54;
(void) mca_base_component_var_register (&mca_mtl_psm_component.super.mtl_version,
"priority", "Priority of the PSM MTL component",
MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,