3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: jsoncpp: Update to 1.9.4

* gnu/packages/serialization.scm (jsoncpp): Update to 1.9.4.
* gnu/packages/patches/jsoncpp-fix-inverted-case.patch: Removed old patch.
* gnu/local.mk (dist_patch_DATA): Remove old patch.

Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
Martin Becze 2020-11-05 07:59:43 -06:00 committed by Christopher Baines
parent 8a59448770
commit 6925c7ec26
No known key found for this signature in database
GPG key ID: 5E28A33B0B84F577
3 changed files with 3 additions and 26 deletions

View file

@ -1182,7 +1182,6 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
%D%/packages/patches/jfsutils-add-sysmacros.patch \
%D%/packages/patches/jfsutils-include-systypes.patch \
%D%/packages/patches/jsoncpp-fix-inverted-case.patch \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/libvirt-create-machine-cgroup.patch \

View file

@ -1,22 +0,0 @@
This patch fixes a bug and related test failure on platforms where 'char'
is unsigned.
Taken from upstream:
https://github.com/open-source-parsers/jsoncpp/commit/f11611c8785082ead760494cba06196f14a06dcb
diff --git a/src/lib_json/json_writer.cpp b/src/lib_json/json_writer.cpp
index 8e06cca2..56195dc1 100644
--- a/src/lib_json/json_writer.cpp
+++ b/src/lib_json/json_writer.cpp
@@ -178,8 +178,9 @@ static bool isAnyCharRequiredQuoting(char const* s, size_t n) {
char const* const end = s + n;
for (char const* cur = s; cur < end; ++cur) {
- if (*cur == '\\' || *cur == '\"' || *cur < ' ' ||
- static_cast<unsigned char>(*cur) < 0x80)
+ if (*cur == '\\' || *cur == '\"' ||
+ static_cast<unsigned char>(*cur) < ' ' ||
+ static_cast<unsigned char>(*cur) >= 0x80)
return true;
}
return false;

View file

@ -10,6 +10,7 @@
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@ -285,16 +286,15 @@ that implements both the msgpack and msgpack-rpc specifications.")
(define-public jsoncpp
(package
(name "jsoncpp")
(version "1.9.2")
(version "1.9.4")
(home-page "https://github.com/open-source-parsers/jsoncpp")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
(patches (search-patches "jsoncpp-fix-inverted-case.patch"))
(sha256
(base32
"037d1b1qdmn3rksmn1j71j26bv4hkjv7sn7da261k853xb5899sg"))))
"0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"