3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: openssh: Update to 8.5p1.

* gnu/packages/patches/openssh-fix-ssh-copy-id.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Also unregister it.
* gnu/packages/ssh.scm (openssh): Update to 8.5p1.
This commit is contained in:
Léo Le Bouter 2021-03-03 06:39:37 +01:00
parent 4bb9bb78c2
commit 759a526f5f
No known key found for this signature in database
GPG key ID: 45A8B1E86BCD10A6
3 changed files with 3 additions and 43 deletions

View file

@ -1426,7 +1426,6 @@ dist_patch_DATA = \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \
%D%/packages/patches/openssh-fix-ssh-copy-id.patch \
%D%/packages/patches/openssh-hurd.patch \
%D%/packages/patches/openresolv-restartcmd-guix.patch \
%D%/packages/patches/opensles-add-license-file.patch \

View file

@ -1,38 +0,0 @@
Fix a bug where ssh-copy-id would fail with "EOF: command not found":
https://github.com/openssh/openssh-portable/pull/206
Patch copied from upstream source repository:
https://github.com/openssh/openssh-portable/commit/d9e727dcc04a52caaac87543ea1d230e9e6b5604
From d9e727dcc04a52caaac87543ea1d230e9e6b5604 Mon Sep 17 00:00:00 2001
From: Oleg <Fallmay@users.noreply.github.com>
Date: Thu, 1 Oct 2020 12:09:08 +0300
Subject: [PATCH] Fix `EOF: command not found` error in ssh-copy-id
---
contrib/ssh-copy-id | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/contrib/ssh-copy-id b/contrib/ssh-copy-id
index 392f64f94..a76907717 100644
--- a/contrib/ssh-copy-id
+++ b/contrib/ssh-copy-id
@@ -247,7 +247,7 @@ installkeys_sh() {
# the -z `tail ...` checks for a trailing newline. The echo adds one if was missing
# the cat adds the keys we're getting via STDIN
# and if available restorecon is used to restore the SELinux context
- INSTALLKEYS_SH=$(tr '\t\n' ' ' <<-EOF)
+ INSTALLKEYS_SH=$(tr '\t\n' ' ' <<-EOF
cd;
umask 077;
mkdir -p $(dirname "${AUTH_KEY_FILE}") &&
@@ -258,6 +258,7 @@ installkeys_sh() {
restorecon -F .ssh ${AUTH_KEY_FILE};
fi
EOF
+ )
# to defend against quirky remote shells: use 'exec sh -c' to get POSIX;
printf "exec sh -c '%s'" "${INSTALLKEYS_SH}"

View file

@ -186,16 +186,15 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
(version "8.4p1")
(version "8.5p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
"openssh-" version ".tar.gz"))
(patches (search-patches "openssh-hurd.patch"
"openssh-fix-ssh-copy-id.patch"))
(patches (search-patches "openssh-hurd.patch"))
(sha256
(base32
"091b3pxdlj47scxx6kkf4agkx8c8sdacdxx8m1dw1cby80pd40as"))))
"09gc8rv7728chxraab85dzkdikaw4aph1wlcwcc9kai9si0kybzm"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)
("pkg-config" ,pkg-config)))