mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: emacs-undohist-el: Update to 0.2.1.
* gnu/packages/emacs-xyz.scm (emacs-undohist-el): Update to 0.2.1. [origin]: Remove unnecessary patch. * gnu/packages/patches/emacs-undohist-ignored.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Apply deletion.
This commit is contained in:
parent
fb5db4e3ab
commit
7abb893c98
3 changed files with 17 additions and 50 deletions
|
@ -960,7 +960,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/emacs-telega-patch-server-functions.patch \
|
||||
%D%/packages/patches/emacs-telega-test-env.patch \
|
||||
%D%/packages/patches/emacs-undohist-ignored.patch \
|
||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||
%D%/packages/patches/enjarify-setup-py.patch \
|
||||
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
||||
|
|
|
@ -8460,29 +8460,24 @@ agree upon.")
|
|||
(license license:gpl3+)))
|
||||
|
||||
(define-public emacs-undohist-el
|
||||
(let ((commit "d2239a5f736724ceb9e3b6bcaa86f4064805cda0")
|
||||
(revision "1"))
|
||||
(package
|
||||
(name "emacs-undohist-el")
|
||||
(version (git-version "0" revision commit))
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/m2ym/undohist-el")
|
||||
(commit commit)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1c0daw246ky7b1x5b8h55x79pl1pjqk1k348l487bdd8zdj4w9wx"))
|
||||
(patches
|
||||
(search-patches "emacs-undohist-ignored.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
(home-page "https://github.com/m2ym/undohist-el")
|
||||
(synopsis "Save undo history between sessions")
|
||||
(description "This package allows persistent use of undo history for
|
||||
(package
|
||||
(name "emacs-undohist-el")
|
||||
(version "0.2.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/m2ym/undohist-el")
|
||||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0hmx2b20nrxg2lb8vplgrzdh8chgxwlbmjvbq5scddggd302sd56"))))
|
||||
(build-system emacs-build-system)
|
||||
(home-page "https://github.com/m2ym/undohist-el")
|
||||
(synopsis "Save undo history between sessions")
|
||||
(description "This package allows persistent use of undo history for
|
||||
individual file buffers.")
|
||||
(license license:gpl3+))))
|
||||
(license license:gpl3+)))
|
||||
|
||||
(define-public emacs-eprime
|
||||
(let ((commit "17a481af26496be91c07139a9bfc05cfe722506f"))
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From 52bfd419bf9022726048f818d955b8ea10a16d5c Mon Sep 17 00:00:00 2001
|
||||
From: Patrick Mosby <info@schreiblogade.de>
|
||||
Date: Mon, 7 Sep 2015 09:05:56 +0200
|
||||
Subject: [PATCH] Don't save undo file for ignored files.
|
||||
|
||||
This fixes #4.
|
||||
---
|
||||
undohist.el | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/undohist.el b/undohist.el
|
||||
index b184a26..de60356 100644
|
||||
--- a/undohist.el
|
||||
+++ b/undohist.el
|
||||
@@ -164,7 +164,8 @@ To use undohist, you just call this function."
|
||||
undohist-ignored-files)))
|
||||
|
||||
(defun undohist-save-1 ()
|
||||
- (when (consp buffer-undo-list)
|
||||
+ (when (and (consp buffer-undo-list)
|
||||
+ (undohist-recover-file-p (buffer-file-name (current-buffer))))
|
||||
(let ((file (make-undohist-file-name (buffer-file-name)))
|
||||
(contents `((digest . ,(md5 (current-buffer)))
|
||||
(undo-list . ,(undohist-encode buffer-undo-list)))))
|
||||
--
|
||||
2.21.0
|
||||
|
Loading…
Reference in a new issue