mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: pulseaudio: Upgrade to 5.0.
* gnu/packages/pulseaudio.scm (pulseaudio): Upgrade to 5.0. Remove patches. * gnu/packages/patches/pulseaudio-test-timeouts.patch, gnu/packages/patches/pulseaudio-volume-test.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
b148bd714e
commit
7c516af641
4 changed files with 2 additions and 55 deletions
|
@ -310,8 +310,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||
gnu/packages/patches/procps-make-3.82.patch \
|
||||
gnu/packages/patches/pulseaudio-test-timeouts.patch \
|
||||
gnu/packages/patches/pulseaudio-volume-test.patch \
|
||||
gnu/packages/patches/python-fix-dbm.patch \
|
||||
gnu/packages/patches/qemu-make-4.0.patch \
|
||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
Increase the timeout of the thread test. Hydra was intermittedly
|
||||
failing this test due to premature timeout, and slower machines
|
||||
consistently fail.
|
||||
|
||||
Patch by Mark H Weaver <mhw@netris.org>.
|
||||
|
||||
--- pulseaudio/src/tests/thread-test.c.orig 2012-09-26 07:27:01.000000000 -0400
|
||||
+++ pulseaudio/src/tests/thread-test.c 2013-10-31 22:53:23.224000184 -0400
|
||||
@@ -152,6 +152,10 @@
|
||||
s = suite_create("Thread");
|
||||
tc = tcase_create("thread");
|
||||
tcase_add_test(tc, thread_test);
|
||||
+ /* the default timeout is too small,
|
||||
+ * set it to a reasonable large one.
|
||||
+ */
|
||||
+ tcase_set_timeout(tc, 60 * 60);
|
||||
suite_add_tcase(s, tc);
|
||||
|
||||
sr = srunner_create(s);
|
|
@ -1,29 +0,0 @@
|
|||
Fix seemingly random failures of 'volume-test' in particular on 32-bit
|
||||
machines. See <https://bugs.freedesktop.org/show_bug.cgi?id=72374> for
|
||||
details.
|
||||
|
||||
From 27e47c72a25846e107b6e450c3a1480a2742382e Mon Sep 17 00:00:00 2001
|
||||
From: Tanu Kaskinen <tanu.kaskinen@linux.intel.com>
|
||||
Date: Sat, 14 Dec 2013 07:21:22 +0000
|
||||
Subject: volume-test: Increase the allowed number of rouding errors
|
||||
|
||||
BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=72374
|
||||
---
|
||||
diff --git a/src/tests/volume-test.c b/src/tests/volume-test.c
|
||||
index a2daf3e..1ab0b5c 100644
|
||||
--- a/src/tests/volume-test.c
|
||||
+++ b/src/tests/volume-test.c
|
||||
@@ -138,7 +138,13 @@ START_TEST (volume_test) {
|
||||
pa_log("max deviation: %lu n=%lu", (unsigned long) md, (unsigned long) mdn);
|
||||
|
||||
fail_unless(md <= 1);
|
||||
- fail_unless(mdn <= 251);
|
||||
+
|
||||
+ /* mdn counts the times there were rounding errors during the test. The
|
||||
+ * number of rounding errors seems to vary slightly depending on the
|
||||
+ * hardware. The original limit was 251 errors, but it was increased to 253
|
||||
+ * when the test was failing on Tanu's laptop.
|
||||
+ * See https://bugs.freedesktop.org/show_bug.cgi?id=72374 */
|
||||
+ fail_unless(mdn <= 253);
|
||||
}
|
||||
END_TEST
|
|
@ -134,7 +134,7 @@ parse JSON formatted strings back into the C representation of JSON objects.")
|
|||
(define pulseaudio
|
||||
(package
|
||||
(name "pulseaudio")
|
||||
(version "4.0")
|
||||
(version "5.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -142,10 +142,7 @@ parse JSON formatted strings back into the C representation of JSON objects.")
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1bndz4l8jxyq3zq128gzp3gryxl6yjs66j2y1d7yabw2n5mv7kim"))
|
||||
(patches (map search-patch
|
||||
'("pulseaudio-test-timeouts.patch"
|
||||
"pulseaudio-volume-test.patch")))))
|
||||
"0fgrr8v7yfh0byhzdv4c87v9lkj8g7gpjm8r9xrbvpa92a5kmhcr"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("--localstatedir=/var" ;"--sysconfdir=/etc"
|
||||
|
|
Loading…
Reference in a new issue