3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: e2fsprogs: Fix build with glibc-2.27.

* gnu/packages/patches/e2fsprogs-glibc-2.27.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/linux.scm (e2fsprogs)[source]: Add patch.
This commit is contained in:
Rutger Helling 2018-05-02 10:07:23 +02:00
parent f0ae90cbbb
commit 7d5adf0131
No known key found for this signature in database
GPG key ID: F3A727DB44FCCA36
3 changed files with 59 additions and 1 deletions

View file

@ -631,6 +631,7 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/doxygen-test.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
%D%/packages/patches/e2fsprogs-glibc-2.27.patch \
%D%/packages/patches/eigen-arm-neon-fixes.patch \
%D%/packages/patches/elfutils-tests-ptrace.patch \
%D%/packages/patches/elixir-disable-failing-tests.patch \

View file

@ -750,7 +750,8 @@ slabtop, and skill.")
name "-" version ".tar.xz"))
(sha256
(base32
"00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))))
"00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))
(patches (search-patches "e2fsprogs-glibc-2.27.patch"))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)

View file

@ -0,0 +1,56 @@
Copied from:
https://github.com/openwrt/openwrt/blob/58a95f0f8ff768b43d68eed2b6a786e0f40f723b/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch
From 01551bdba16ab16512a01affe02ade32c41ede8a Mon Sep 17 00:00:00 2001
From: Palmer Dabbelt <palmer@dabbelt.com>
Date: Fri, 29 Dec 2017 10:19:51 -0800
Subject: [PATCH] misc: rename copy_file_range to copy_file_chunk
As of 2.27, glibc will have a copy_file_range library call to wrap the
new copy_file_range system call. This conflicts with the function in
misc/create_inode.c, which this patch renames _copy_file_range.
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
---
misc/create_inode.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
--- a/misc/create_inode.c
+++ b/misc/create_inode.c
@@ -392,7 +392,7 @@ static ssize_t my_pread(int fd, void *bu
}
#endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
-static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
+static errcode_t copy_file_chunk(ext2_filsys fs, int fd, ext2_file_t e2_file,
off_t start, off_t end, char *buf,
char *zerobuf)
{
@@ -466,7 +466,7 @@ static errcode_t try_lseek_copy(ext2_fil
data_blk = data & ~(fs->blocksize - 1);
hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
- err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
+ err = copy_file_chunk(fs, fd, e2_file, data_blk, hole_blk, buf,
zerobuf);
if (err)
return err;
@@ -516,7 +516,7 @@ static errcode_t try_fiemap_copy(ext2_fi
}
for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
i++, ext++) {
- err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
+ err = copy_file_chunk(fs, fd, e2_file, ext->fe_logical,
ext->fe_logical + ext->fe_length,
buf, zerobuf);
if (err)
@@ -569,7 +569,7 @@ static errcode_t copy_file(ext2_filsys f
goto out;
#endif
- err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
+ err = copy_file_chunk(fs, fd, e2_file, 0, statbuf->st_size, buf,
zerobuf);
out:
ext2fs_free_mem(&zerobuf);