mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
arb: Update to 2.18.1.
* gnu/packages/patches/arb-flint-2.6.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/algebra.scm (arb): Update to 2.18.1. [source](patches): Remove.
This commit is contained in:
parent
e239135c56
commit
7dcf529673
3 changed files with 3 additions and 53 deletions
|
@ -1,6 +1,6 @@
|
|||
# GNU Guix --- Functional package management for GNU
|
||||
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Andreas Enge <andreas@enge.fr>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Andreas Enge <andreas@enge.fr>
|
||||
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
|
||||
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
||||
|
@ -775,7 +775,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
||||
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
|
||||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
%D%/packages/patches/arb-flint-2.6.patch \
|
||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||
|
|
|
@ -495,7 +495,7 @@ fast arithmetic.")
|
|||
(define-public arb
|
||||
(package
|
||||
(name "arb")
|
||||
(version "2.17.0")
|
||||
(version "2.18.1")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -504,8 +504,7 @@ fast arithmetic.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"05lpy3hkl5f8ik19aw40cqydrb932xaf2n8hbq9ib5dnk7f010p1"))
|
||||
(patches (search-patches "arb-flint-2.6.patch"))))
|
||||
"15fx3dcbzgwddw9p1nysmx0dbh058afv5m8cj5pdjkcmcl7kw7z9"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("flint" ,flint))) ; flint.h is included by arf.h
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
From d3d9983231e0f034e86a1e75761627eb8213b704 Mon Sep 17 00:00:00 2001
|
||||
From: fredrik <fredrik.johansson@gmail.com>
|
||||
Date: Wed, 29 Apr 2020 13:41:36 +0200
|
||||
Subject: [PATCH] handle flint incompatibilities
|
||||
|
||||
---
|
||||
fmpr.h | 4 ++++
|
||||
fmpz_extras.h | 4 ++++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/fmpr.h b/fmpr.h
|
||||
index 2204d72e..c6a8c342 100644
|
||||
--- a/fmpr.h
|
||||
+++ b/fmpr.h
|
||||
@@ -22,7 +22,11 @@
|
||||
#include "flint/flint.h"
|
||||
#include "flint/fmpz.h"
|
||||
#include "flint/fmpq.h"
|
||||
+#if __FLINT_RELEASE < 20600
|
||||
#include "flint/config.h"
|
||||
+#else
|
||||
+#include "flint/flint-config.h"
|
||||
+#endif
|
||||
#include "fmpz_extras.h"
|
||||
|
||||
#ifndef flint_abort
|
||||
diff --git a/fmpz_extras.h b/fmpz_extras.h
|
||||
index 4fd0538f..486e28c8 100644
|
||||
--- a/fmpz_extras.h
|
||||
+++ b/fmpz_extras.h
|
||||
@@ -43,6 +43,8 @@ fmpz_add_inline(fmpz_t z, const fmpz_t x, const fmpz_t y)
|
||||
fmpz_add(z, x, y);
|
||||
}
|
||||
|
||||
+#if __FLINT_RELEASE < 20600
|
||||
+
|
||||
static __inline__ void
|
||||
fmpz_add_si(fmpz_t z, const fmpz_t x, slong y)
|
||||
{
|
||||
@@ -61,6 +63,8 @@ fmpz_sub_si(fmpz_t z, const fmpz_t x, slong y)
|
||||
fmpz_add_ui(z, x, -y);
|
||||
}
|
||||
|
||||
+#endif
|
||||
+
|
||||
static __inline__ void
|
||||
fmpz_add_si_inline(fmpz_t z, const fmpz_t x, slong y)
|
||||
{
|
Loading…
Reference in a new issue