3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: sbc: Fix build on non-x86 architectures.

* gnu/packages/patches/sbc-fix-build-non-x86.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/linux.scm (sbc)[source](patches): New field.
This commit is contained in:
Marius Bakke 2020-12-21 23:38:22 +01:00
parent 166472e2c8
commit 85ba5e9335
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 0 deletions

View file

@ -1600,6 +1600,7 @@ dist_patch_DATA = \
%D%/packages/patches/rust-reproducible-builds.patch \
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
%D%/packages/patches/sbc-fix-build-non-x86.patch \
%D%/packages/patches/sbcl-clml-fix-types.patch \
%D%/packages/patches/scalapack-blacs-mpi-deprecations.patch \
%D%/packages/patches/scheme48-tests.patch \

View file

@ -4654,6 +4654,7 @@ event traces from the kernel (via the relaying through the debug file system).")
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/bluetooth/sbc-"
version ".tar.xz"))
(patches (search-patches "sbc-fix-build-non-x86.patch"))
(sha256
(base32
"1liig5856crb331dps18mp0s13zbkv7yh007zqhq97m94fcddfhc"))))

View file

@ -0,0 +1,17 @@
Don't refer to x86-specific function on other architectures to avoid linker error.
Submitted upstream at <https://marc.info/?l=linux-bluetooth&m=160857625608440&w=2>
diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
--- a/sbc/sbc_primitives.c
+++ b/sbc/sbc_primitives.c
@@ -593,7 +593,9 @@ static int sbc_calc_scalefactors_j(
static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
{
+#if defined(__x86_64__) || defined(__i386__)
__builtin_cpu_init();
+#endif
#ifdef SBC_BUILD_WITH_MMX_SUPPORT
if (__builtin_cpu_supports("mmx"))