mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: sddm: Fix CMake build.
* gnu/packages/display-managers.scm (sddm): Fix CMake build. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch: New file. Signed-off-by: Rutger Helling <rhelling@mykolab.com>
This commit is contained in:
parent
8fc3a971b0
commit
8674abb1dd
3 changed files with 32 additions and 1 deletions
|
@ -1093,6 +1093,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-graph-diam-64.patch \
|
||||
%D%/packages/patches/scotch-graph-induce-type-64.patch \
|
||||
%D%/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -6,6 +6,7 @@
|
|||
;;; Copyright © 2017 Sou Bunnbu <iyzsong@gmail.com>
|
||||
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -143,7 +144,8 @@ Qt-style API for Wayland clients.")
|
|||
"sddm-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ch6rdppgy2vbzw0c2x9a4c6ry46vx7p6b76d8xbh2nvxh23xv0k"))))
|
||||
"0ch6rdppgy2vbzw0c2x9a4c6ry46vx7p6b76d8xbh2nvxh23xv0k"))
|
||||
(patches (search-patches "sddm-fix-build-with-qt-5.11-1024.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("extra-cmake-modules" ,extra-cmake-modules)
|
||||
|
|
28
gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch
Normal file
28
gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2efc649..8903b52 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -93,7 +95,7 @@
|
||||
find_package(XKB REQUIRED)
|
||||
|
||||
# Qt 5
|
||||
-find_package(Qt5 5.6.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools)
|
||||
+find_package(Qt5 5.8.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools Test)
|
||||
|
||||
# find qt5 imports dir
|
||||
get_target_property(QMAKE_EXECUTABLE Qt5::qmake LOCATION)
|
||||
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
||||
index c9d935a..bb85ddd 100644
|
||||
--- a/test/CMakeLists.txt
|
||||
+++ b/test/CMakeLists.txt
|
||||
@@ -2,9 +2,8 @@
|
||||
|
||||
include_directories(../src/common)
|
||||
|
||||
-
|
||||
set(ConfigurationTest_SRCS ConfigurationTest.cpp ../src/common/ConfigReader.cpp)
|
||||
add_executable(ConfigurationTest ${ConfigurationTest_SRCS})
|
||||
add_test(NAME Configuration COMMAND ConfigurationTest)
|
||||
|
||||
-qt5_use_modules(ConfigurationTest Test)
|
||||
+target_link_libraries(ConfigurationTest Qt5::Core Qt5::Test)
|
Loading…
Reference in a new issue