3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: evolution: Fix building with cmake > 3.20.

* gnu/packages/patches/evolution-printableoptions.patch: New file.
* gnu/packages/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (evolution)[source]: Use it.
This commit is contained in:
Guillaume Le Vaillant 2021-08-30 13:27:10 +02:00
parent bbb0420e44
commit 8948bc7e44
No known key found for this signature in database
GPG key ID: 6BE8208ADF21FE3F
3 changed files with 61 additions and 2 deletions

View file

@ -20,7 +20,7 @@
# Copyright © 2018, 2019, 2020, 2021 Oleg Pykhalov <go.wigust@gmail.com>
# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
# Copyright © 2018, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
# Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
# Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
@ -1006,6 +1006,7 @@ dist_patch_DATA = \
%D%/packages/patches/eudev-rules-directory.patch \
%D%/packages/patches/evilwm-lost-focus-bug.patch \
%D%/packages/patches/evolution-CVE-2020-11879.patch \
%D%/packages/patches/evolution-printableoptions.patch \
%D%/packages/patches/evolution-data-server-CVE-2020-14928.patch \
%D%/packages/patches/evolution-data-server-CVE-2020-16117.patch \
%D%/packages/patches/evolution-data-server-printableoptions.patch \

View file

@ -10701,7 +10701,8 @@ generic enough to work for everyone.")
(sha256
(base32
"164vy8h432pjglafn8y2ms4gsvk3kbgc63h5qp0mk5dv4smsp29c"))
(patches (search-patches "evolution-CVE-2020-11879.patch"))))
(patches (search-patches "evolution-CVE-2020-11879.patch"
"evolution-printableoptions.patch"))))
(build-system cmake-build-system)
(arguments
`(#:imported-modules (,@%cmake-build-system-modules

View file

@ -0,0 +1,57 @@
Patch adapted from evolution-data-server's
c3915bb99638c1ccf57217097b14b5db69bcac96 upstream patch by Milan Crha:
PrintableOptions.cmake: Correct variable name comparison
CMake 3.20.1 errors out with:
CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
variable name cannot be empty
Call Stack (most recent call first):
CMakeLists.txt:152 (add_printable_variable)
Change how the parameter value is compared, to fix it.
--- a/cmake/modules/PrintableOptions.cmake
+++ b/cmake/modules/PrintableOptions.cmake
@@ -19,32 +19,32 @@
# prints all the build options previously added with the above functions
macro(add_printable_variable_bare _name)
- if(_name STREQUAL "")
+ if("${_name}" STREQUAL "")
message(FATAL_ERROR "variable name cannot be empty")
- endif(_name STREQUAL "")
+ endif("${_name}" STREQUAL "")
list(APPEND _printable_options ${_name})
endmacro()
macro(add_printable_option _name _description _default_value)
- if(_name STREQUAL "")
+ if("${_name}" STREQUAL "")
message(FATAL_ERROR "option name cannot be empty")
- endif(_name STREQUAL "")
+ endif("${_name}" STREQUAL "")
option(${_name} ${_description} ${_default_value})
add_printable_variable_bare(${_name})
endmacro()
macro(add_printable_variable _name _description _default_value)
- if(_name STREQUAL "")
+ if("${_name}" STREQUAL "")
message(FATAL_ERROR "variable name cannot be empty")
- endif(_name STREQUAL "")
+ endif("${_name}" STREQUAL "")
set(${_name} ${_default_value} CACHE STRING ${_description})
add_printable_variable_bare(${_name})
endmacro()
macro(add_printable_variable_path _name _description _default_value)
- if(_name STREQUAL "")
+ if("${_name}" STREQUAL "")
message(FATAL_ERROR "path variable name cannot be empty")
- endif(_name STREQUAL "")
+ endif("${_name}" STREQUAL "")
set(${_name} ${_default_value} CACHE PATH ${_description})
add_printable_variable_bare(${_name})
endmacro()