3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: python-shiboken-2: Update to 5.15.10.

* gnu/packages/qt.scm (python-shiboken-2): Update to 5.15.10.
[source]: Use mirror://qt for the source URL.  Delete patches.
* gnu/packages/patches/python-shiboken-2-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
Maxim Cournoyer 2023-08-22 10:53:23 -04:00
parent 79b44a92e5
commit 9c08ba358e
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 4 additions and 22 deletions

View file

@ -1728,7 +1728,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
%D%/packages/patches/python-sip-include-dirs.patch \
%D%/packages/patches/python-sgmllib3k-assertions.patch \
%D%/packages/patches/python-shiboken-2-compat.patch \
%D%/packages/patches/python-telingo-fix-comparison.patch \
%D%/packages/patches/python-typeguard-python3.10.patch \
%D%/packages/patches/python-w3lib-fix-test-failure.patch \

View file

@ -1,15 +0,0 @@
Backport a fix from 5.15.9, mentioned in [1].
[1] https://bugreports.qt.io/browse/PYSIDE-2176
--- pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/pep384impl.cpp 2023-04-24 11:05:48.770934499 +0200
+++ pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/pep384impl.cpp 2023-04-24 11:04:51.566943936 +0200
@@ -751,7 +751,7 @@
#endif // IS_PY2
Shiboken::AutoDecRef privateobj(PyObject_GetAttr(
reinterpret_cast<PyObject *>(Py_TYPE(self)), Shiboken::PyMagicName::name()));
-#ifndef Py_LIMITED_API
+#ifdef IS_PY2
return _Py_Mangle(privateobj, name);
#else
// PYSIDE-1436: _Py_Mangle is no longer exposed; implement it always.

View file

@ -4179,17 +4179,15 @@ color-related widgets.")
(define-public python-shiboken-2
(package
(name "python-shiboken-2")
(version "5.15.8")
(version "5.15.10")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases"
"/QtForPython/pyside2/PySide2-" version
"-src/pyside-setup-opensource-src-"
(uri (string-append "mirror://qt/QtForPython/pyside2/PySide2-"
version "-src/pyside-setup-opensource-src-"
version ".tar.xz"))
(sha256
(base32
"0pbbdypwkn3vrgy8ww207fl8pqq4jv80bck9qz5v9dfyr0166hr3"))
(patches (search-patches "python-shiboken-2-compat.patch"))))
"0fnkx8ax2lkin3bpqbz4zbdrdin2ixb4d6s3c0xghh9sc79r3xia"))))
(build-system cmake-build-system)
(inputs
(list clang-toolchain