3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: python-random2: Fix building with python 3.9.

* gnu/packages/patches/python-random2-getrandbits-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python-xyz.scm (python-random2)[source]: Use it.
This commit is contained in:
Guillaume Le Vaillant 2021-09-11 14:16:46 +02:00
parent 0321c098d3
commit 9cfa0078e6
No known key found for this signature in database
GPG key ID: 6BE8208ADF21FE3F
3 changed files with 27 additions and 1 deletions

View file

@ -1548,6 +1548,7 @@ dist_patch_DATA = \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \
%D%/packages/patches/python-chai-drop-python2.patch \
%D%/packages/patches/python-random2-getrandbits-test.patch \
%D%/packages/patches/sdcc-disable-non-free-code.patch \
%D%/packages/patches/sdl-pango-api_additions.patch \
%D%/packages/patches/sdl-pango-blit_overflow.patch \

View file

@ -0,0 +1,23 @@
From 1bac6355d9c65de847cc445d782c466778b94fbd Mon Sep 17 00:00:00 2001
From: "Robert T. McGibbon" <rmcgibbo@gmail.com>
Date: Sun, 9 May 2021 11:18:23 -0400
Subject: [PATCH] Update tests for python3.9
---
src/tests.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/tests.py b/src/tests.py
index d918891..4f2c3de 100644
--- a/src/tests.py
+++ b/src/tests.py
@@ -448,7 +448,8 @@ def test_genrandbits(self):
self.assertRaises(TypeError, self.gen.getrandbits)
self.assertRaises(TypeError, self.gen.getrandbits, 'a')
self.assertRaises(TypeError, self.gen.getrandbits, 1, 2)
- self.assertRaises(ValueError, self.gen.getrandbits, 0)
+ if sys.version_info < (3, 9):
+ self.assertRaises(ValueError, self.gen.getrandbits, 0)
self.assertRaises(ValueError, self.gen.getrandbits, -1)
def test_randbelow_logic(self, _log=log, int=int):

View file

@ -16179,7 +16179,9 @@ focus on building massively scalable web applications.")
(uri (pypi-uri "random2" version ".zip"))
(sha256
(base32
"01y0s4747plsx8fdnxy0nz83dp69naddz58m81r9h0s1qfm31b9l"))))
"01y0s4747plsx8fdnxy0nz83dp69naddz58m81r9h0s1qfm31b9l"))
(patches
(search-patches "python-random2-getrandbits-test.patch"))))
(build-system python-build-system)
(native-inputs `(("unzip" ,unzip)))
(home-page "http://pypi.python.org/pypi/random2")