3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: Remove unused scotch patches.

* gnu/packages/patches/scotch-build-parallelism.patch: Delete file.
* gnu/packages/patches/scotch-integer-declarations.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): De-register them.
This commit is contained in:
Maxim Cournoyer 2022-10-02 22:23:09 -04:00
parent 8ad1978695
commit a93781b83c
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 0 additions and 78 deletions

View file

@ -1823,8 +1823,6 @@ dist_patch_DATA = \
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
%D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scons-test-environment.patch \
%D%/packages/patches/scotch-build-parallelism.patch \
%D%/packages/patches/scotch-integer-declarations.patch \
%D%/packages/patches/screen-hurd-path-max.patch \
%D%/packages/patches/sdl-libx11-1.6.patch \
%D%/packages/patches/seed-webkit.patch \

View file

@ -1,39 +0,0 @@
Fixes make with -j, otherwise scotch.h may not be generated by the time make
tries to compile library_graph_diam.o et al.
Reported upstream at
https://gforge.inria.fr/tracker/index.php?func=detail&aid=21651&group_id=248&atid=1081
diff --git a/src/libscotch/Makefile b/src/libscotch/Makefile
index 9898894..b0ee14c 100644
--- a/src/libscotch/Makefile
+++ b/src/libscotch/Makefile
@@ -2229,6 +2229,28 @@ library_graph_color_f$(OBJ) : library_graph_color_f.c \
common.h \
scotch.h
+library_graph_diam$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ graph.h \
+ scotch.h
+
+library_graph_diam_f$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ scotch.h
+
+library_graph_induce$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ graph.h \
+ scotch.h
+
+library_graph_induce_f$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ scotch.h
+
library_graph_io_chac$(OBJ) : library_graph_io_chac.c \
module.h \
common.h \

View file

@ -1,37 +0,0 @@
diff --git a/src/libscotch/library.h b/src/libscotch/library.h
index 1891c19..ecc0533 100644
--- a/src/libscotch/library.h
+++ b/src/libscotch/library.h
@@ -67,6 +67,8 @@
/*+ Integer type. +*/
+#include <stdint.h>
+
typedef DUMMYIDX SCOTCH_Idx;
typedef DUMMYINT SCOTCH_Num;
diff --git a/src/libscotchmetis/library_metis.h b/src/libscotchmetis/library_metis.h
index e6767e1..04e71c3 100644
--- a/src/libscotchmetis/library_metis.h
+++ b/src/libscotchmetis/library_metis.h
@@ -99,6 +99,7 @@ typedef enum {
*/
#ifndef SCOTCH_H /* In case "scotch.h" not included before */
+#include <stdint.h>
typedef DUMMYINT SCOTCH_Num;
#endif /* SCOTCH_H */
diff --git a/src/libscotchmetis/library_parmetis.h b/src/libscotchmetis/library_parmetis.h
index 6d2f0b0..3c803fc 100644
--- a/src/libscotchmetis/library_parmetis.h
+++ b/src/libscotchmetis/library_parmetis.h
@@ -106,6 +106,7 @@ typedef enum {
*/
#ifndef SCOTCH_H /* In case "scotch.h" not included before */
+#include <stdint.h>
typedef DUMMYINT SCOTCH_Num;
#endif /* SCOTCH_H */