mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
Merge branch 'master' into core-updates
This commit is contained in:
commit
ab9da9ec66
4 changed files with 56 additions and 13 deletions
|
@ -51,6 +51,7 @@
|
|||
(package
|
||||
(name "curl")
|
||||
(version "7.59.0")
|
||||
(replacement curl-7.60.0)
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://curl.haxx.se/download/curl-"
|
||||
|
@ -140,6 +141,19 @@ tunneling, and so on.")
|
|||
"See COPYING in the distribution."))
|
||||
(home-page "https://curl.haxx.se/")))
|
||||
|
||||
(define-public curl-7.60.0
|
||||
(package
|
||||
(inherit curl)
|
||||
(version "7.60.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://curl.haxx.se/download/curl-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1876ck0smbqz3xakm7s6q6gh4zarh9pv3izf4vlzgpc9xn6zydl7"))))))
|
||||
|
||||
(define-public kurly
|
||||
(package
|
||||
(name "kurly")
|
||||
|
|
|
@ -98,7 +98,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
|
|||
(define-public isc-bind
|
||||
(package
|
||||
(name "bind")
|
||||
(version "9.12.1")
|
||||
(version "9.12.1-P2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -106,7 +106,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"043mjcw405qa0ghm5dkhfsq35gsy279724fz3mjqpr1mbi14dr0n"))))
|
||||
"0a9dvyg1dk7vpqn9gz7p5jas3bz7z22bjd66b98g1qk16i2w7rqd"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs `("out" "utils"))
|
||||
(inputs
|
||||
|
|
|
@ -670,14 +670,14 @@ by Robert Shea and Robert Anton Wilson.")
|
|||
(define-public procps
|
||||
(package
|
||||
(name "procps")
|
||||
(version "3.3.12")
|
||||
(version "3.3.14")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
|
||||
"procps-ng-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1m57w6jmry84njd5sgk5afycbglql0al80grx027kwqqcfw5mmkf"))))
|
||||
"0v3j6rkzzscqds37i105cxx3q4dk04rsgpqfd5p7hzcvk59h5njy"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:modules ((guix build utils)
|
||||
|
@ -686,15 +686,6 @@ by Robert Shea and Robert Anton Wilson.")
|
|||
(srfi srfi-26))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'check 'disable-strtod-test
|
||||
(lambda _
|
||||
;; Disable the 'strtod' test, which fails on 32-bit systems.
|
||||
;; This is what upstream does:
|
||||
;; <https://gitlab.com/procps-ng/procps/commit/100afbc1491be388f1429021ff65d969f4b1e08f>.
|
||||
(substitute* "Makefile"
|
||||
(("^(TESTS|check_PROGRAMS) = .*$" all)
|
||||
(string-append "# " all "\n")))
|
||||
#t))
|
||||
(add-after
|
||||
'install 'post-install
|
||||
;; Remove commands and man pages redudant with
|
||||
|
|
38
gnu/packages/patches/pius.patch
Normal file
38
gnu/packages/patches/pius.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
See https://github.com/jaymzh/pius/pull/96
|
||||
|
||||
commit 4dba0bf75ab351969622f7b9c38484657411a528
|
||||
Author: Martin Kletzander <nert.pinx+github@gmail.com>
|
||||
Date: Thu May 17 17:55:27 2018 +0200
|
||||
|
||||
Don't fail on ENCRYPTION_COMPLIANCE_MODE line from too new GnuPG (#96)
|
||||
|
||||
GnuPG started printing information about encryption compliance in [commit
|
||||
f31dc2540acf](https://dev.gnupg.org/rGf31dc2540acf7cd7f09fd94658e815822222bfcb)
|
||||
and since then signing with pius fails.
|
||||
|
||||
Closes #95
|
||||
|
||||
Signed-off-by: Martin Kletzander <nert.pinx@gmail.com>
|
||||
|
||||
diff --git a/libpius/signer.py b/libpius/signer.py
|
||||
index 3c7262f..13013bb 100644
|
||||
--- a/libpius/signer.py
|
||||
+++ b/libpius/signer.py
|
||||
@@ -45,6 +45,7 @@ class PiusSigner(object):
|
||||
GPG_PINENTRY_LAUNCHED = '[GNUPG:] PINENTRY_LAUNCHED'
|
||||
GPG_KEY_CONSIDERED = '[GNUPG:] KEY_CONSIDERED'
|
||||
GPG_WARN_VERSION = '[GNUPG:] WARNING server_version_mismatch'
|
||||
+ GPG_ENC_COMPLIANT_MODE = '[GNUPG:] ENCRYPTION_COMPLIANCE_MODE'
|
||||
|
||||
def __init__(self, signer, force_signer, mode, keyring, gpg_path, tmpdir,
|
||||
outdir, encrypt_outfiles, mail, mailer, verbose, sort_keyring,
|
||||
@@ -431,6 +432,9 @@ class PiusSigner(object):
|
||||
if PiusSigner.GPG_ENC_BEG in line:
|
||||
debug('Got GPG_ENC_BEG')
|
||||
continue
|
||||
+ elif PiusSigner.GPG_ENC_COMPLIANT_MODE in line:
|
||||
+ debug('Got ENCRYPTION_COMPLIANCE_MODE')
|
||||
+ continue
|
||||
elif PiusSigner.GPG_ENC_END in line:
|
||||
debug('Got GPG_ENC_END')
|
||||
break
|
Loading…
Reference in a new issue