3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: bsdiff: Fix CVE-2014-9862.

* gnu/packages/patches/bsdiff-CVE-2014-9862.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/compression.scm (bsdiff): Apply it.
This commit is contained in:
Léo Le Bouter 2021-03-10 09:50:14 +01:00
parent 207ef1a2b4
commit b66fc0a64b
No known key found for this signature in database
GPG key ID: 45A8B1E86BCD10A6
3 changed files with 18 additions and 1 deletions

View file

@ -840,6 +840,7 @@ dist_patch_DATA = \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
%D%/packages/patches/bc-fix-cross-compilation.patch \
%D%/packages/patches/bear-disable-preinstall-tests.patch \
%D%/packages/patches/bsdiff-CVE-2014-9862.patch \
%D%/packages/patches/bsd-games-2.17-64bit.patch \
%D%/packages/patches/bsd-games-add-configure-config.patch \
%D%/packages/patches/bsd-games-add-wrapper.patch \

View file

@ -963,7 +963,8 @@ tarballs.")
(uri (string-append home-page name "-" version ".tar.gz"))
(sha256
(base32
"0j2zm3z271x5aw63mwhr3vymzn45p2vvrlrpm9cz2nywna41b0hq"))))
"0j2zm3z271x5aw63mwhr3vymzn45p2vvrlrpm9cz2nywna41b0hq"))
(patches (search-patches "bsdiff-CVE-2014-9862.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "INSTALL=install"

View file

@ -0,0 +1,15 @@
diff --git a/bspatch.c b/bspatch.c
index 8d95633..ab77722 100644
--- a/bspatch.c
+++ b/bspatch.c
@@ -187,6 +187,10 @@
};
/* Sanity-check */
+ if ((ctrl[0] < 0) || (ctrl[1] < 0))
+ errx(1,"Corrupt patch\n");
+
+ /* Sanity-check */
if(newpos+ctrl[0]>newsize)
errx(1,"Corrupt patch\n");