mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: postgresql: Fix finding extensions.
* gnu/packages/patches/postgresql-disable-resolve_symlinks.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/databases.scm (postgresql)[source]: Use it.
This commit is contained in:
parent
030c912616
commit
c336567dad
3 changed files with 29 additions and 2 deletions
|
@ -1042,6 +1042,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||
%D%/packages/patches/portaudio-audacity-compat.patch \
|
||||
%D%/packages/patches/portmidi-modular-build.patch \
|
||||
%D%/packages/patches/postgresql-disable-resolve_symlinks.patch \
|
||||
%D%/packages/patches/potrace-tests.patch \
|
||||
%D%/packages/patches/procmail-ambiguous-getline-debian.patch \
|
||||
%D%/packages/patches/procmail-CVE-2014-3618.patch \
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
|
||||
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
|
||||
;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
|
||||
;;; Copyright © 2017, 2018 Julien Lepiller <julien@lepiller.eu>
|
||||
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
|
||||
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
|
||||
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
|
||||
|
@ -814,7 +814,8 @@ as a drop-in replacement of MySQL.")
|
|||
version "/postgresql-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"04a07jkvc5s6zgh6jr78149kcjmsxclizsqabjw44ld4j5n633kc"))))
|
||||
"04a07jkvc5s6zgh6jr78149kcjmsxclizsqabjw44ld4j5n633kc"))
|
||||
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("--with-uuid=e2fs")
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
From 223c82d1d6ed1f29f26307249827ff679e09c780 Mon Sep 17 00:00:00 2001
|
||||
From: Julien Lepiller <julien@lepiller.eu>
|
||||
Date: Sat, 28 Jul 2018 12:22:12 +0200
|
||||
Subject: [PATCH] disable resolve_symlink
|
||||
|
||||
---
|
||||
src/common/exec.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/common/exec.c b/src/common/exec.c
|
||||
index 878fc29..6b3e283 100644
|
||||
--- a/src/common/exec.c
|
||||
+++ b/src/common/exec.c
|
||||
@@ -218,6 +218,8 @@ find_my_exec(const char *argv0, char *retpath)
|
||||
static int
|
||||
resolve_symlinks(char *path)
|
||||
{
|
||||
+ // On GuixSD we *want* stuff relative to symlinks.
|
||||
+ return 0;
|
||||
#ifdef HAVE_READLINK
|
||||
struct stat buf;
|
||||
char orig_wd[MAXPGPATH],
|
||||
--
|
||||
2.18.0
|
||||
|
Loading…
Reference in a new issue