3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: Remove broken xf86 video drivers.

Those packages build failed with current xorg-server:
  openchrome: multiple definition of some functions.
  other: missing headers for xf86RamDac.h, IBM.h, etc.

* gnu/packages/xorg.scm (xf86-video-glint, xf86-video-openchrome
xf86-video-suncg6, xf86-video-sunffb, xf86-video-tga
xf86-video-trident): Remove packages.
* gnu/packages/patches/xf86-video-tga-remove-mibstore.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
宋文武 2023-01-31 15:27:38 +08:00
parent 7493ff7ae3
commit c53e8404e8
No known key found for this signature in database
GPG key ID: D415BF253B515976
3 changed files with 0 additions and 184 deletions

View file

@ -2006,7 +2006,6 @@ dist_patch_DATA = \
%D%/packages/patches/xf86-video-nouveau-fixup-ABI.patch \
%D%/packages/patches/xf86-video-savage-xorg-compat.patch \
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
%D%/packages/patches/xf86-video-tga-remove-mibstore.patch \
%D%/packages/patches/xfce4-panel-plugins.patch \
%D%/packages/patches/xfce4-settings-defaults.patch \
%D%/packages/patches/xgboost-use-system-dmlc-core.patch \

View file

@ -1,34 +0,0 @@
Removes references to mibstore.h and miInitializeBackingStore, which
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
wrote: "It was a noop for at least 5 years and it has been removed."
See: http://patches.openembedded.org/patch/46133/
--- xf86-video-tga-1.2.2/src/tga_accel.c.~1~ 2012-07-15 23:54:04.000000000 -0400
+++ xf86-video-tga-1.2.2/src/tga_accel.c 2014-12-19 01:40:27.535913013 -0500
@@ -37,7 +37,6 @@
#include "xf86cmap.h"
#include "mipointer.h"
-#include "mibstore.h"
#include "miline.h"
#include "tga_regs.h"
--- xf86-video-tga-1.2.2/src/tga_driver.c.~1~ 2012-07-15 23:54:28.000000000 -0400
+++ xf86-video-tga-1.2.2/src/tga_driver.c 2014-12-19 01:40:48.756018238 -0500
@@ -46,8 +46,6 @@
/* software cursor */
#include "mipointer.h"
-/* backing store */
-#include "mibstore.h"
/* #include "mibank.h" */
/* colormap manipulation */
@@ -1451,7 +1449,6 @@
fbPictureInit (pScreen, 0, 0);
- miInitializeBackingStore(pScreen);
xf86SetBackingStore(pScreen);
xf86SetSilkenMouse(pScreen);

View file

@ -2841,30 +2841,6 @@ compositing. Both support Xv overlay and dynamic rotation with XRandR.")
;; "xf86-video-glide is a Glide video driver for the Xorg X server.")
;; (license license:x11)))
(define-public xf86-video-glint
(package
(name "xf86-video-glint")
(version "1.2.9")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-glint-"
version
".tar.bz2"))
(sha256
(base32
"1lkpspvrvrp9s539bhfdjfh4andaqyk63l6zjn8m3km95smk6a45"))))
(build-system gnu-build-system)
(inputs (list xorgproto xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "GLINT/Permedia video driver for X server")
(description
"xf86-video-glint is a GLINT/Permedia video driver for the Xorg
X server.")
(license license:x11)))
(define-public xf86-video-i128
(package
(name "xf86-video-i128")
@ -3077,37 +3053,6 @@ supported, and the RENDER extension is not accelerated by this driver.")
graphics cards.")
(license license:x11)))
(define-public xf86-video-openchrome
(package
(name "xf86-video-openchrome")
(version "0.6.0")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-openchrome-"
version
".tar.bz2"))
(sha256
(base32
"0x9gq3hw6k661k82ikd1y2kkk4dmgv310xr5q59dwn4k6z37aafs"))))
(build-system gnu-build-system)
(inputs (list libx11
libxext
libxvmc
mesa
xorgproto
xorg-server))
(native-inputs
(list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "Openchrome video driver for X server")
(description
"xf86-video-openchrome is a video driver for the Xorg X server.
This driver is intended for VIA chipsets featuring the VIA UniChrome,
UniChrome Pro and Chrome9 integrated graphics processors.")
(license license:x11)))
(define-public xf86-video-qxl
(package
(name "xf86-video-qxl")
@ -3227,52 +3172,6 @@ Xorg X server.")
This driver supports SiS chipsets of 300/315/330/340 series.")
(license license:bsd-3)))
(define-public xf86-video-suncg6
(package
(name "xf86-video-suncg6")
(version "1.1.3")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-suncg6-"
version
".tar.xz"))
(sha256
(base32
"16c3g5m0f5y9nx2x6w9jdzbs9yr6xhq31j37dcffxbsskmfxq57w"))))
(build-system gnu-build-system)
(inputs (list xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "GX/TurboGX video driver for X server")
(description
"xf86-video-suncg6 is a GX/TurboGX video driver for the Xorg X server.")
(license license:x11)))
(define-public xf86-video-sunffb
(package
(name "xf86-video-sunffb")
(version "1.2.3")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-sunffb-"
version
".tar.xz"))
(sha256
(base32
"0pf4ddh09ww7sxpzs5gr9pxh3gdwkg3f54067cp802nkw1n8vypi"))))
(build-system gnu-build-system)
(inputs (list xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "SUNFFB video driver for X server")
(description
"xf86-video-sunffb is a SUNFFB video driver for the Xorg X server.")
(license license:x11)))
(define-public xf86-video-tdfx
(package
(name "xf86-video-tdfx")
@ -3296,54 +3195,6 @@ This driver supports SiS chipsets of 300/315/330/340 series.")
"xf86-video-tdfx is a 3Dfx video driver for the Xorg X server.")
(license license:x11)))
(define-public xf86-video-tga
(package
(name "xf86-video-tga")
(version "1.2.2")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-tga-"
version
".tar.bz2"))
(sha256
(base32
"0cb161lvdgi6qnf1sfz722qn38q7kgakcvj7b45ba3i0020828r0"))
(patches (search-patches "xf86-video-tga-remove-mibstore.patch"))))
(build-system gnu-build-system)
(inputs (list xorgproto xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "TGA video driver for X server")
(description
"xf86-video-tga is a TGA (DEC 21030) video driver for the Xorg
X server.")
(license license:x11)))
(define-public xf86-video-trident
(package
(name "xf86-video-trident")
(version "1.3.8")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-trident-"
version
".tar.bz2"))
(sha256
(base32
"0gxcar434kx813fxdpb93126lhmkl3ikabaljhcj5qn3fkcijlcy"))))
(build-system gnu-build-system)
(inputs (list xorgproto xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "Trident video driver for X server")
(description
"xf86-video-trident is a Trident video driver for the Xorg X server.")
(license license:x11)))
;; no license
;; (define-public xf86-video-v4l