3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: zsh: Patch failing test that uses egrep.

* gnu/packages/patches/zsh-egrep-failing-test.patch: New file.
* gnu/packages/shells.scm (zsh): Patch it.
* gnu/local.mk (dist_patch_DATA): Register it.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
This commit is contained in:
Josselin Poiret 2023-03-30 23:48:18 +02:00 committed by Guillaume Le Vaillant
parent 7f7532a847
commit cebcf3533a
No known key found for this signature in database
GPG key ID: 6BE8208ADF21FE3F
3 changed files with 15 additions and 2 deletions

View file

@ -2040,7 +2040,8 @@ dist_patch_DATA = \
%D%/packages/patches/xterm-370-explicit-xcursor.patch \
%D%/packages/patches/xygrib-fix-finding-data.patch \
%D%/packages/patches/yggdrasil-extra-config.patch \
%D%/packages/patches/zig-use-system-paths.patch
%D%/packages/patches/zig-use-system-paths.patch \
%D%/packages/patches/zsh-egrep-failing-test.patch
MISC_DISTRO_FILES = \
%D%/packages/ld-wrapper.in

View file

@ -0,0 +1,11 @@
--- a/Test/E01options.ztst 2023-03-30 21:34:12.372309112 +0200
+++ b/Test/E01options.ztst 2023-03-30 21:34:33.212335339 +0200
@@ -649,7 +649,7 @@
>noktarg1
>0 1
- showopt() { setopt | egrep 'localoptions|ksharrays'; }
+ showopt() { setopt | grep -E 'localoptions|ksharrays'; }
f1() { setopt localoptions ksharrays; showopt }
f2() { setopt ksharrays; showopt }
setopt kshoptionprint

View file

@ -467,7 +467,8 @@ history mechanism, job control and a C-like syntax.")
".tar.xz")))
(sha256
(base32
"06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))))
"06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))
(patches (search-patches "zsh-egrep-failing-test.patch"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags
`("--with-tcsetpgrp"