3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: aws-c-compression: Update to 0.2.14.

* gnu/packages/c.scm (aws-c-compression): Update to 0.2.14.
[arguments]: Fix CMAKE_PREFIX_PATH.
[source]: Remove patch.
* gnu/packages/patches/aws-c-compression-cmake-prefix.patch:
Delete file.
* gnu/local.mk: Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-10-18 17:36:24 +00:00 committed by Ludovic Courtès
parent 1a0ed46097
commit cff8a12a0a
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 6 additions and 18 deletions

View file

@ -872,7 +872,6 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-auth-cmake-prefix.patch \
%D%/packages/patches/aws-c-auth-disable-networking-tests.patch\
%D%/packages/patches/aws-c-compression-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-mqtt-cmake-prefix.patch \
%D%/packages/patches/aws-c-s3-cmake-prefix.patch \

View file

@ -750,7 +750,8 @@ specifications.")
(define-public aws-c-compression
(package
(name "aws-c-compression")
(version "0.2.13")
; Update only when updating aws-crt-cpp.
(version "0.2.14")
(source (origin
(method git-fetch)
(uri (git-reference
@ -759,12 +760,13 @@ specifications.")
(file-name (git-file-name name version))
(sha256
(base32
"0zqfxi0fdgapfsfgvsindv63pq7vyl1s376qkpv4jgflyb1v6gp5"))
(patches (search-patches "aws-c-compression-cmake-prefix.patch"))))
"0fs3zhhzxsb9nfcjpvfbcq79hal7si2ia1c09scab9a8m264f4vd"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(list "-DBUILD_SHARED_LIBS=ON"
(string-append "-DCMAKE_PREFIX_PATH="
(assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)))
(synopsis "Amazon Web Services compression library")

View file

@ -1,13 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,10 @@ if (POLICY CMP0069)
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
endif()
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()