3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: tremc: Update to 0.9.3.

* gnu/packages/bittorrent.scm (tremc): Update to 0.9.3.
[source]: Remove obsolete patch.
* gnu/packages/patches/tremc-fix-decodestring.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Leo Famulari 2022-03-24 22:47:18 -04:00
parent f252e6b8bf
commit d05fcc21cb
No known key found for this signature in database
GPG key ID: 2646FA30BACA7F08
3 changed files with 2 additions and 29 deletions

View file

@ -1862,7 +1862,6 @@ dist_patch_DATA = \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transfig-gcc10-fno-common.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
%D%/packages/patches/tremc-fix-decodestring.patch \
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \
%D%/packages/patches/trytond-add-guix_trytond_path.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \

View file

@ -226,7 +226,7 @@ XML-RPC over SCGI.")
(define-public tremc
(package
(name "tremc")
(version "0.9.2")
(version "0.9.3")
(source
(origin
(method git-fetch)
@ -236,8 +236,7 @@ XML-RPC over SCGI.")
(file-name (git-file-name name version))
(sha256
(base32
"1fqspp2ckafplahgba54xmx0sjidx1pdzyjaqjhz0ivh98dkx2n5"))
(patches (search-patches "tremc-fix-decodestring.patch"))))
"11izsgwj435skkgvw96an6ddcm1hk3ff1gji4ksnidlyv6g6npyv"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite

View file

@ -1,25 +0,0 @@
From 79995bc82e81f0429222aab4d90a03440feef057 Mon Sep 17 00:00:00 2001
From: Matan Ziv-Av <matan@svgalib.org>
Date: Mon, 29 Jun 2020 15:18:03 +0300
Subject: [PATCH] Use base64.decodebytes.
Based on upstream commit 79995bc82e81f0429222aab4d90a03440feef057 which
confuses several unrelated changes.
---
tremc | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)
diff --git a/tremc b/tremc
index b47f012..c626fde 100755
--- a/tremc
+++ b/tremc
@@ -440,7 +443,7 @@ class Transmission(object):
# TAG_TORRENT_DETAILS, but just passing seems to help.(?)
try:
torrent_details = response['arguments']['torrents'][0]
- torrent_details['pieces'] = base64.decodestring(bytes(torrent_details['pieces'], ENCODING))
+ torrent_details['pieces'] = base64.decodebytes(bytes(torrent_details['pieces'], ENCODING))
self.torrent_details_cache = torrent_details
self.upgrade_peerlist()
except IndexError: