3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: appstream-glib: Fix test failure.

* gnu/packages/patches/appstream-glib-2020.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/glib.scm (appstream-glib)[source](patches): New field.
This commit is contained in:
Marius Bakke 2020-01-07 15:49:01 +01:00
parent 1ecadbfe60
commit d2e1b2dac7
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 33 additions and 0 deletions

View file

@ -709,6 +709,7 @@ dist_patch_DATA = \
%D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
%D%/packages/patches/appstream-glib-2020.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/arm-trusted-firmware-disable-hdcp.patch \
%D%/packages/patches/arm-trusted-firmware-optional-bin-generation.patch \

View file

@ -904,6 +904,7 @@ programming language. It also contains the utility
(uri (string-append "https://people.freedesktop.org/~hughsient/"
"appstream-glib/releases/"
"appstream-glib-" version ".tar.xz"))
(patches (search-patches "appstream-glib-2020.patch"))
(sha256
(base32
"14jr1psx5kxywdprgbqn79w309yz8lrqlsq7288hfrf87gbr1wh4"))))

View file

@ -0,0 +1,31 @@
2020 is no longer the future.
Taken from upstream:
https://github.com/hughsie/appstream-glib/commit/953c8e529d7291e60a95e580967ed79ce2c9ccf0
diff --git a/data/tests/broken.appdata.xml b/data/tests/broken.appdata.xml
index f7a5386e..cf80f5b4 100644
--- a/data/tests/broken.appdata.xml
+++ b/data/tests/broken.appdata.xml
@@ -40,7 +40,7 @@
<p>This is a duplicate release on the same day!</p>
</description>
</release>
- <release date="2020-01-01" version="0.6.2">
+ <release date="2050-01-01" version="0.6.2">
<description>
<p>This is a release in the future!</p>
</description>
diff --git a/libappstream-glib/as-app-validate.c b/libappstream-glib/as-app-validate.c
index c1103ace..f50e4e41 100644
--- a/libappstream-glib/as-app-validate.c
+++ b/libappstream-glib/as-app-validate.c
@@ -864,7 +864,7 @@ as_app_validate_release (AsApp *app,
AS_PROBLEM_KIND_ATTRIBUTE_MISSING,
"<release> has no timestamp");
}
- if (timestamp > 20120101 && timestamp < 20251231) {
+ if (timestamp > 20120101 && timestamp < 20351231) {
ai_app_validate_add (helper,
AS_PROBLEM_KIND_ATTRIBUTE_INVALID,
"<release> timestamp should be a UNIX time");