gnu: Add aws-c-http.

* gnu/packages/c.scm (aws-c-http): New variable.
* gnu/packages/patches/aws-c-http-cmake-prefix.patch,
gnu/packages/patches/aws-c-http-disable-networking-tests.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-04-30 13:58:33 +00:00 committed by Ludovic Courtès
parent d061193e78
commit d9b8cfd6c6
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
4 changed files with 94 additions and 0 deletions

View File

@ -871,6 +871,8 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-cal-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-disable-networking-tests.patch\
%D%/packages/patches/aws-c-io-cmake-prefix.patch \
%D%/packages/patches/aws-c-io-disable-networking-tests.patch \
%D%/packages/patches/aws-checksums-cmake-prefix.patch \

View File

@ -712,3 +712,34 @@ cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
(description "The @acronym{PCL, Portable Coroutine Library} implements the
low level functionality for coroutines.")
(license license:gpl2+)))
(define-public aws-c-http
(package
(name "aws-c-http")
(version "0.6.4")
(source (origin
(method git-fetch)
(uri (git-reference
(url (string-append "https://github.com/awslabs/" name))
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"18xlgz68zizkcp784bs6hkyx0gvp0f1p076i46z653bcd3qa87b4"))
(patches
(search-patches
"aws-c-http-cmake-prefix.patch"
"aws-c-http-disable-networking-tests.patch"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(propagated-inputs
`(("aws-c-compression" ,aws-c-compression)
("aws-c-io" ,aws-c-io)))
(synopsis "Amazon Web Services HTTP library")
(description
"This library provides a C99 implementation of the HTTP/1.1 and HTTP/2
specifications.")
(home-page "https://github.com/awslabs/aws-c-http")
(license license:asl2.0)))

View File

@ -0,0 +1,13 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,10 @@ endif()
option(ENABLE_PROXY_INTEGRATION_TESTS "Whether to run the proxy integration tests that rely on a proxy server installed and running locally" OFF)
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()

View File

@ -0,0 +1,48 @@
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -136,8 +136,8 @@ add_test_case(strutil_trim_http_whitespace)
add_test_case(strutil_is_http_token)
add_test_case(strutil_is_lowercase_http_token)
-add_net_test_case(tls_download_medium_file_h1)
-add_net_test_case(tls_download_medium_file_h2)
+#add_net_test_case(tls_download_medium_file_h1)
+#add_net_test_case(tls_download_medium_file_h2)
add_test_case(websocket_decoder_sanity_check)
add_test_case(websocket_decoder_simplest_frame)
@@ -438,21 +438,21 @@ add_test_case(connection_setup_shutdown)
# connection manager tests
# unit tests where connections are mocked
-add_net_test_case(test_connection_manager_setup_shutdown)
-add_net_test_case(test_connection_manager_acquire_release_mix_synchronous)
-add_net_test_case(test_connection_manager_connect_callback_failure)
-add_net_test_case(test_connection_manager_connect_immediate_failure)
-add_net_test_case(test_connection_manager_proxy_setup_shutdown)
-add_net_test_case(test_connection_manager_idle_culling_single)
-add_net_test_case(test_connection_manager_idle_culling_many)
-add_net_test_case(test_connection_manager_idle_culling_mixture)
+#add_net_test_case(test_connection_manager_setup_shutdown)
+#add_net_test_case(test_connection_manager_acquire_release_mix_synchronous)
+#add_net_test_case(test_connection_manager_connect_callback_failure)
+#add_net_test_case(test_connection_manager_connect_immediate_failure)
+#add_net_test_case(test_connection_manager_proxy_setup_shutdown)
+#add_net_test_case(test_connection_manager_idle_culling_single)
+#add_net_test_case(test_connection_manager_idle_culling_many)
+#add_net_test_case(test_connection_manager_idle_culling_mixture)
# tests where we establish real connections
-add_net_test_case(test_connection_manager_single_connection)
-add_net_test_case(test_connection_manager_many_connections)
-add_net_test_case(test_connection_manager_acquire_release)
-add_net_test_case(test_connection_manager_close_and_release)
-add_net_test_case(test_connection_manager_acquire_release_mix)
+#add_net_test_case(test_connection_manager_single_connection)
+#add_net_test_case(test_connection_manager_many_connections)
+#add_net_test_case(test_connection_manager_acquire_release)
+#add_net_test_case(test_connection_manager_close_and_release)
+#add_net_test_case(test_connection_manager_acquire_release_mix)
add_test_case(h1_server_sanity_check)