mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
gnu: emacs-unpackaged-el: Update to 0-2.c0d58cf.
* gnu/packages/emacs-xyz.scm (emacs-unpackaged-el): Update to 0-2.c0d58cf. * gnu/packages/patches/emacs-unpackaged-req.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
760ea03789
commit
dc95c8b497
3 changed files with 11 additions and 30 deletions
|
@ -792,7 +792,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||||
%D%/packages/patches/emacs-unpackaged-req.patch \
|
|
||||||
%D%/packages/patches/emacs-undohist-ignored.patch \
|
%D%/packages/patches/emacs-undohist-ignored.patch \
|
||||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||||
%D%/packages/patches/emacs-zones-called-interactively.patch \
|
%D%/packages/patches/emacs-zones-called-interactively.patch \
|
||||||
|
|
|
@ -614,8 +614,8 @@ from within Emacs.")
|
||||||
(license license:gpl3+)))
|
(license license:gpl3+)))
|
||||||
|
|
||||||
(define-public emacs-unpackaged-el
|
(define-public emacs-unpackaged-el
|
||||||
(let ((commit "f4df7f8dfea715e893b2223adda32545803f5cce")
|
(let ((commit "c0d58cf81e531b2b6fa1bd5dd612dc1b93d4d186")
|
||||||
(revision "1"))
|
(revision "2"))
|
||||||
(package
|
(package
|
||||||
(name "emacs-unpackaged-el")
|
(name "emacs-unpackaged-el")
|
||||||
(version (git-version "0" revision commit))
|
(version (git-version "0" revision commit))
|
||||||
|
@ -628,9 +628,7 @@ from within Emacs.")
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1yf3zrgqfhnr0az8gn1kqqwnhfi3nc0vbjkcagwcqwk3sp1jda86"))
|
"0y3sgvd51l4pb3acps92bazfk49da6nim1f1hyxzy1ravg4kbw83"))))
|
||||||
(patches
|
|
||||||
(search-patches "emacs-unpackaged-req.patch"))))
|
|
||||||
(build-system emacs-build-system)
|
(build-system emacs-build-system)
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("emacs-dash" ,emacs-dash)
|
`(("emacs-dash" ,emacs-dash)
|
||||||
|
@ -638,6 +636,14 @@ from within Emacs.")
|
||||||
("emacs-s" ,emacs-s)
|
("emacs-s" ,emacs-s)
|
||||||
("emacs-hydra" ,emacs-hydra)
|
("emacs-hydra" ,emacs-hydra)
|
||||||
("emacs-use-package" ,emacs-use-package)))
|
("emacs-use-package" ,emacs-use-package)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'require-hydra
|
||||||
|
(lambda _
|
||||||
|
(substitute* "unpackaged.el"
|
||||||
|
((";;; Code:") ";;; Code:\n(require 'hydra)"))
|
||||||
|
#t)))))
|
||||||
(home-page "https://github.com/alphapapa/unpackaged.el")
|
(home-page "https://github.com/alphapapa/unpackaged.el")
|
||||||
(synopsis "Useful snippets of Emacs Lisp code")
|
(synopsis "Useful snippets of Emacs Lisp code")
|
||||||
(description "This package provides Emacs Lisp utilities for a variety
|
(description "This package provides Emacs Lisp utilities for a variety
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
From e5be173e201710538464c279335bef735a327a68 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Brian Leung <bkleung89@gmail.com>
|
|
||||||
Date: Tue, 18 Jun 2019 06:37:46 +0200
|
|
||||||
Subject: [PATCH] Add missing require.
|
|
||||||
|
|
||||||
---
|
|
||||||
unpackaged.el | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/unpackaged.el b/unpackaged.el
|
|
||||||
index 2d46b3c..e62184a 100644
|
|
||||||
--- a/unpackaged.el
|
|
||||||
+++ b/unpackaged.el
|
|
||||||
@@ -38,6 +38,7 @@
|
|
||||||
(require 'dash)
|
|
||||||
(require 's)
|
|
||||||
(require 'use-package)
|
|
||||||
+(require 'hydra)
|
|
||||||
|
|
||||||
;;; Faces, fonts
|
|
||||||
|
|
||||||
--
|
|
||||||
2.22.0
|
|
||||||
|
|
Loading…
Reference in a new issue