3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: gawk: Update to 4.1.4.

* gnu/packages/gawk.scm (gawk): Update to 4.1.4.
[source]: Remove 'patches'.
[arguments]: Add 'adjust-test-infrastructure' phase.
* gnu/packages/patches/gawk-fts-test.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
Ludovic Courtès 2016-09-02 15:35:37 +02:00
parent 67fcf2358c
commit e0649ff3c0
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 18 additions and 56 deletions

View file

@ -512,7 +512,6 @@ dist_patch_DATA = \
%D%/packages/patches/fontforge-svg-modtime.patch \
%D%/packages/patches/fossil-test-fixes.patch \
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
%D%/packages/patches/gawk-fts-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
%D%/packages/patches/gcc-cross-environment-variables.patch \

View file

@ -29,14 +29,13 @@
(define-public gawk
(package
(name "gawk")
(version "4.1.3")
(version "4.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
(base32 "09d6pmx6h3i2glafm0jd1v1iyrs03vcyv2rkz12jisii3vlmbkz3"))
(patches (search-patches "gawk-fts-test.patch"))))
(base32 "0rn2mmjxm767zliqzd67j7h2ncjn4j0321c60y9fy3grs3i89qak"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
@ -59,7 +58,22 @@
(string-append "### " match))))
'())))
%standard-phases)))
(alist-cons-before
'check 'adjust-test-infrastructure
(lambda _
;; Remove dependency on 'more' (from util-linux), which
;; would needlessly complicate bootstrapping.
(substitute* "test/Makefile"
(("\\| more") ""))
;; Adjust the shebang in that file since it is then diff'd
;; against the actual test output.
(substitute* "test/watchpoint1.ok"
(("#! /usr/bin/gawk")
(string-append "#!" (which "gawk"))))
#t)
%standard-phases))))
(inputs `(("libsigsegv" ,libsigsegv)
,@(if (%current-target-system)

View file

@ -1,51 +0,0 @@
This is upstream commit c9a018c. We have observed random failures of
this test on i686 that seem related to load.
2015-05-21 Arnold D. Robbins <arnold@skeeve.com>
* fts.awk: Really remove atime from the output.
This avoids spurious failures on heavily loaded systems.
diff --git a/test/fts.awk b/test/fts.awk
index b1df060..dea5b68 100644
--- a/test/fts.awk
+++ b/test/fts.awk
@@ -50,6 +50,11 @@ function sort_traverse(data, sorted, i)
{
asorti(data, sorted)
for (i = 1; i in sorted; i++) {
+ # 5/2015: skip for atime, since there can
+ # occasionally be small differences.
+ if (sorted[i] == "atime")
+ continue
+
indent()
printf("%s --> %s\n", sorted[i], data[sorted[i]]) > output
}
@@ -63,17 +68,20 @@ function traverse(data, i)
printf("%s:\n", i) > output
Level++
- if (("mtime" in data[i]) && ! isarray(data[i][mtime])) {
+ if (("mtime" in data[i]) && ! isarray(data[i]["mtime"])) {
sort_traverse(data[i])
} else {
traverse(data[i])
}
Level--
- } else if (data[i] != "atime") {
- # 4/2015: skip for atime, since there can
- # occasionally be small differences.
- indent()
- printf("%s --> %s\n", i, data[i]) > output
+# } else {
+# JUNK = 1
+# if (i != "atime") {
+# # 4/2015: skip for atime, since there can
+# # occasionally be small differences.
+# indent()
+# printf("%s --> %s\n", i, data[i]) > output
+# }
}
}
}