3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: plasma-framework: Fix build errors in dependent packages.

Fix build errors in dependent packages if PREFIX is different from ECM's
PREFIX - which is the case in Guix.  See <https://bugs.kde.org/424483> for
details.

* gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch: New
  file.
* gnu/local.mk (dist_patch_DATA) Add it.
* packages/kde-frameworks.scm (plasma-framework)[source]: Use this patch.
This commit is contained in:
Hartmut Goebel 2020-10-25 19:47:38 +01:00
parent fc6bced6c5
commit e3908ec5fb
No known key found for this signature in database
GPG key ID: 634A8DFFD3F631DF
3 changed files with 28 additions and 1 deletions

View file

@ -1410,6 +1410,7 @@ dist_patch_DATA = \
%D%/packages/patches/pam-mount-luks2-support.patch \
%D%/packages/patches/pango-skip-libthai-test.patch \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/samba-fix-fcntl-hint-detection.patch \
%D%/packages/patches/sdl-pango-api_additions.patch \

View file

@ -3449,7 +3449,8 @@ setUrl, setUserAgent and call.")
name "-" version ".tar.xz"))
(sha256
(base32
"06cxajsxj62g3c37ssrrcaxb9a12zbyp2kvrjqym329k5vd89272"))))
"06cxajsxj62g3c37ssrrcaxb9a12zbyp2kvrjqym329k5vd89272"))
(patches (search-patches "plasma-framework-fix-KF5PlasmaMacros.cmake.patch"))))
(build-system cmake-build-system)
(propagated-inputs
`(("kpackage" ,kpackage)

View file

@ -0,0 +1,25 @@
From ff5ed26f21d304e867ab57781878069567deb23d Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Mon, 3 Aug 2020 19:49:58 +0000
Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
See <https://bugs.kde.org/424483> for details
---
KF5PlasmaMacros.cmake | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/KF5PlasmaMacros.cmake b/KF5PlasmaMacros.cmake
index 494b42d56..80b3fd8dd 100644
--- a/KF5PlasmaMacros.cmake
+++ b/KF5PlasmaMacros.cmake
@@ -1,6 +1,5 @@
-find_package(ECM 1.6.0 CONFIG REQUIRED)
-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
+include(KDEInstallDirs)
set(PLASMA_RELATIVE_DATA_INSTALL_DIR "plasma")
set(PLASMA_DATA_INSTALL_DIR "${KDE_INSTALL_DATADIR}/${PLASMA_RELATIVE_DATA_INSTALL_DIR}")
--
GitLab